LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-28-2017, 01:03 AM   #1
Vernicronz
Member
 
Registered: Jul 2014
Distribution: Redhat,Centos,Ubuntu
Posts: 50

Rep: Reputation: Disabled
Unhappy Trying to change eth0 speed to 1000mbps but failing


Hi ,
I am trying to change my network speed on my centos 6.4 box , but unable to change. I have tried the following , but to no avail. Appreciate some advice. Thank you.

before changing
Code:
[root@mx/]# ethtool eth0
Settings for eth0:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Supported pause frame use: Symmetric
	Supports auto-negotiation: Yes
	Advertised link modes:  1000baseT/Full 
	Advertised pause frame use: Symmetric
	Advertised auto-negotiation: Yes
	Speed: 100Mb/s
	Duplex: Full
	Port: Twisted Pair
	PHYAD: 1
	Transceiver: internal
	Auto-negotiation: on
	MDI-X: Unknown
	Supports Wake-on: pumbg
	Wake-on: g
	Current message level: 0x00000007 (7)
			       drv probe link
	Link detected: yes
After changing - lost network connectivity ( this was done inside ILO )
Code:
[root@mx/]# ethtool -s eth0 speed 1000 duplex full autoneg on
[root@mx/]# 
[root@mx/]# ethtool eth0
Settings for eth0:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Supported pause frame use: Symmetric
	Supports auto-negotiation: Yes
	Advertised link modes:  1000baseT/Full 
	Advertised pause frame use: Symmetric
	Advertised auto-negotiation: Yes
	Speed: Unknown!
	Duplex: Unknown! (255)
	Port: Twisted Pair
	PHYAD: 1
	Transceiver: internal
	Auto-negotiation: on
	MDI-X: Unknown
	Supports Wake-on: pumbg
	Wake-on: g
	Current message level: 0x00000007 (7)
			       drv probe link
	Link detected: no
to revert back , i had to restart the network . not sure what is wrong. 1st time seing this kind of issue
 
Old 12-28-2017, 01:24 AM   #2
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,298

Rep: Reputation: 555Reputation: 555Reputation: 555Reputation: 555Reputation: 555Reputation: 555
Is your cabling and connected device (router?) interface capable of supporting this speed? Normally auto-negotiation should achieve the same if the connected interfaces are capable.
 
Old 12-28-2017, 01:31 AM   #3
Vernicronz
Member
 
Registered: Jul 2014
Distribution: Redhat,Centos,Ubuntu
Posts: 50

Original Poster
Rep: Reputation: Disabled
hi ferrari ,

the server is connected to a Pro Curve switch , other servers are in the segment are having no issue. Not sure why just this server is having this issue.
 
Old 12-28-2017, 01:52 AM   #4
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,298

Rep: Reputation: 555Reputation: 555Reputation: 555Reputation: 555Reputation: 555Reputation: 555
You'll need to check the switch port configuration.
 
Old 12-28-2017, 02:10 AM   #5
Vernicronz
Member
 
Registered: Jul 2014
Distribution: Redhat,Centos,Ubuntu
Posts: 50

Original Poster
Rep: Reputation: Disabled
Hi ferrari ,

i am getting this from the nic info, this could mean the cable is not supporting the 1000mbps rite.

Code:
[root@mx/]# lshw -C network
  *-network:0             
       description: Ethernet interface
       product: I350 Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 01
       serial: fc:15:b4:10:a6:84
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi msix pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=igb driverversion=4.0.1-k duplex=full firmware=1.59, 0x08d28000, 1.349.0 ip=10.0.0.119 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:16 memory:fbc00000-fbcfffff ioport:5000(size=32) memory:fbbf0000-fbbf3fff memory:be100000-be17ffff(prefetchable) memory:be300000-be31ffff(prefetchable) memory:be320000-be33ffff(prefetchable)
 
Old 12-28-2017, 02:43 AM   #6
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,298

Rep: Reputation: 555Reputation: 555Reputation: 555Reputation: 555Reputation: 555Reputation: 555
The cable or switch port configuration are both possibilities. Do you have an ethernet cable tester available for checking the cable parameters?
 
Old 12-28-2017, 02:57 AM   #7
Vernicronz
Member
 
Registered: Jul 2014
Distribution: Redhat,Centos,Ubuntu
Posts: 50

Original Poster
Rep: Reputation: Disabled
Hi ferrari ,
I am away from the DC atm , will be only be able to go DC tomorrow and have the cable replaced and check again the speed
. Will update again here tomorrow. Thanks again so much...
 
Old 12-28-2017, 02:36 PM   #8
jefro
Moderator
 
Registered: Mar 2008
Posts: 18,481

Rep: Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770
I agree on the cable. Even so called tested ones can do this.

However every once in a while you have to fully power down systems. For some reason the nic can get locked into the auto or select one speed and refuse to change. Both server and router may need to do this and keep cable off till you manually select speeds. Remove the auto negot.
 
Old 12-28-2017, 10:49 PM   #9
Vernicronz
Member
 
Registered: Jul 2014
Distribution: Redhat,Centos,Ubuntu
Posts: 50

Original Poster
Rep: Reputation: Disabled
hi ferrari & jefro ,

turns out to be the cable the actual culprit , did the cable change and verified the speed ..set to 1000mbps and working fine. thanks so much.
I never reboot the server , works fine with 1207 days uptime . Happy New Year 2018 !! Thanks so much.

Code:
[root@mx / ~]# lshw -C network
  *-network:0             
       description: Ethernet interface
       product: I350 Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 01
       serial: fc:15:b4:10:a6:84
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi msix pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=igb driverversion=4.0.1-k duplex=full firmware=1.59, 0x08d28000, 1.349.0 ip=10.0.0.119 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:16 memory:fbc00000-fbcfffff ioport:5000(size=32) memory:fbbf0000-fbbf3fff memory:be100000-be17ffff(prefetchable) memory:be300000-be31ffff(prefetchable) memory:be320000-be33ffff(p


[root@mx/ ~]# ethtool -s eth0 speed 1000 duplex full autoneg off
[root@mx/ ~]# ethtool eth0
Settings for eth0:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Supported pause frame use: Symmetric
	Supports auto-negotiation: Yes
	Advertised link modes:  1000baseT/Full 
	Advertised pause frame use: Symmetric
	Advertised auto-negotiation: Yes
	Speed: 1000Mb/s
	Duplex: Full
	Port: Twisted Pair
	PHYAD: 1
	Transceiver: internal
	Auto-negotiation: on
	MDI-X: Unknown
	Supports Wake-on: pumbg
	Wake-on: g
	Current message level: 0x00000007 (7)
			       drv probe link
	Link detected: yes
 
Old 12-28-2017, 11:00 PM   #10
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,298

Rep: Reputation: 555Reputation: 555Reputation: 555Reputation: 555Reputation: 555Reputation: 555
Glad to read of your success with this!
 
Old 12-29-2017, 03:48 PM   #11
jefro
Moderator
 
Registered: Mar 2008
Posts: 18,481

Rep: Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770
Next time remove the cable for a minute or two and try. See if cable or jabber is cause.

Thanks for the update.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow data transmit speed upto 55kbps on bonded NIC which is 1000Mbps capable! Kamal Luthra Linux - Networking 2 06-29-2015 02:38 AM
Problem in configuring speed of NIC (LAN) to 1000Mbps uk.engr Linux - Hardware 2 05-29-2012 08:49 AM
[SOLVED] Slave NIS server failing upon disabling eth0 the_gripmaster Linux - Server 4 03-21-2011 11:23 PM
eth0 failing to set up axon Linux - Networking 3 10-27-2004 04:58 AM
Eth0 is failing after updating to kernel 2.4.4 mantiev Linux - Networking 10 05-07-2001 01:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration