-   Linux - Networking (
-   -   trying to auto mount xp share in fstab (

babag 07-11-2008 06:43 PM

trying to auto mount xp share in fstab
this isn't mounting:

//\ (E) /home/xfers/mnt/d200 smbfs username=username,password=password,fmask=0777,dmask=0777 0 0
getting the error:

[mntent]: line 5 in /etc/fstab is bad
if i try a 'mount -a'

what's wrong here?

i am able to log into the share via smb4k without issue.
i also am able to share a folder within the drive (this is
an entire shared drive) in fstab.


mandriva 2007.1

jschiwal 07-11-2008 06:53 PM

Depending on your kernel version, use cifs instead of smbfs. Smbfs is depreciated. Having spaces and evil characters in the share definition is a bad idea. Use a legal share name. The first entry should be the name of the share and not the directory being shared. I'm not sure how the mount command parses the fstab file but it seams that you are partially confusing escaping spaces in bash, but bash doesn't read the fstab file. ( I say partially because the "(" and ")" would be escaped in bash as well. You may also have the share name and comment mixed up. The first field looks more like a command than a share name.

babag 07-11-2008 06:59 PM

just tried cifs and got same error.

don't know how to alter the share name. the drive is
just named 'Capture'. xp seems to be adding the ' (E)'
to the equation. in any event, i'd be hesitant to
make too many changes in this area as there's a lot
of things already hung onto this particular name.
wish i could just get a way to make the name work,
however xp is feeding it.


jschiwal 07-12-2008 04:48 AM

smbclient -L <xp_ip_address>
After authenticating, the services will be listed. I still think that you are using the description and not the name. Use the name of the service instead. I believe that if you didn't manually create a discription for the service, that XP is using the name but adding that extra " (E)" at the end.

Another thing you could do is browse to that host, for example, enter in konqueror:

All times are GMT -5. The time now is 04:54 PM.