-   Linux - Networking (
-   -   trouble with a broadcom b4311 rev 1 wifi adapter. (

oznola 06-19-2011 06:18 PM

trouble with a broadcom b4311 rev 1 wifi adapter.

i have a broadcom BCM4311 802.11b/g WLAN [14e4:4311] (rev 01) wireless adapter on a dell 1501 run by ubuntu 10.10.

this particular model and revision is suppose to be absolutely supported by linux and indeed it did work perfectly before the user ran a upgrade from ubuntu 10.10 to 11.04.

subsequently i have reinstalled 10.10. as i recall when i installed ubuntu 10.10 the first time i simply ran the System>Admin>Additional Driver installation tool to make the wireless work. i cannot recall if i ran the b43 or the sta driver but i have tried both this time and had no luck.

i am aware that the broadcom adapters are notoriously troublesome and i have tried the two workarounds here as well as their third alternate workaround with no success.

please advise if you can.

thank you.

mmrr 06-20-2011 02:05 AM

possible help
hi oznola,

i remembered seeing stuff on puppylinux forum about these units.
so i entered 'trouble with a broadcom b4311 rev 1 wifi adapter'
at ...lots of hits

i took a quick look at the first one:
which looked as if it might be useful--it included a critical
lib as a zipped download,,but i didn't check if download is alive.

anyway, there's lot's of info there, hope some is helpful.

cheers, mm

oznola 06-20-2011 06:17 PM


i found a solution that worked for me here...

i removed the sta driver and then deployed Alternate Solution 2 given in the link. i do hope it works for you.

thank you for help.:jawa:

jschiwal 06-20-2011 07:48 PM

Look at `lsmod' and see which broadcom wireless kernel module is loaded. If they both are, one needs to be blacklisted.

Another possibility is that the firmware for the b43 driver is missing and you need to use b43-fwcutter to reinstall it. If you have a backup of /lib/modules/ you could restore them (if you didn't change arch size, 32 or 64 bit).

All times are GMT -5. The time now is 03:28 PM.