LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 03-19-2003, 12:58 AM   #1
nilantha
LQ Newbie
 
Registered: Mar 2003
Posts: 2

Rep: Reputation: 0
Question tree connect failed: NT_STATUS_BAD_NETWORK_NAME


I am a newbie to samba and linux. I configured smb.conf and now I can browse Linux share from NT and windows machines. But when I try to catch NT share trough linux it gives the following message. When browse through Nautilus I can go up to shared directories. From prompt I tried out smbclient as follws and it give the following message. Pl help me.

[root@nilantha samba]# smbclient //internal/slarmy -U nilantha
added interface ip=202.51.141.134 bcast=202.51.141.143 nmask=255.255.255.240
Got a positive name query response from 202.51.141.142 ( 202.51.141.142 202.51.141.141 )
Password:
Domain=[ITWEB] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME


Regards,

Nilantha
 
Old 03-19-2003, 04:16 AM   #2
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
try xsmbrowser, da?

get it from this link:

http://freshmeat.net/projects/xsmbrowser/?topic_id=150
 
Old 08-02-2003, 10:43 AM   #3
pingram
LQ Newbie
 
Registered: Jul 2003
Posts: 2

Rep: Reputation: 0
you couldn't let us have a copy of your smb.conf file as a starters reference could you. ive been struggling with NT/Linux via Samba for some time and still can't get the ***** thing to work!
 
Old 08-02-2003, 11:00 AM   #4
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 46
either samba could not resolve the system name internal OR it could not find the slarmy share
 
Old 10-20-2003, 02:34 AM   #5
edpowerzzz
LQ Newbie
 
Registered: Oct 2003
Location: Davao City, Philippines
Distribution: RedHat 9.0
Posts: 1

Rep: Reputation: 0
yup had the same problem.. but after a lot of frustrating tweaks voila! it works now!.. don't even remember how i did it exactly.. just know that i fixed smbd and nmbd services... you might want to check that out too...
 
Old 06-19-2008, 10:04 AM   #6
alpartis
LQ Newbie
 
Registered: Jun 2008
Posts: 1

Rep: Reputation: 1
Had the same problem ... spent the better part of a day trying to work through it. For me, the error message set me up for failure by leading me down the wrong path looking for a solution. The real underlying problem was directory permissions two directories above in the path.

Be sure the entire path has at least golbal 'read' permissions set!

A quick 'chmod 755 dir' solved the problem for me. Zounds!

-ap
 
Old 11-05-2008, 11:14 PM   #7
wanghao
Member
 
Registered: Mar 2007
Distribution: centos
Posts: 126

Rep: Reputation: 15
Thanks for you post ,i encounterd the same problem that you said the chmod the dir flag could resolv the issue.And which dir should be chmod the current?or the spcified?
Thanks in advznce!








All you best!
 
Old 12-08-2008, 11:57 PM   #8
BassKozz
Member
 
Registered: Dec 2008
Distribution: Ubuntu 8.10
Posts: 35

Rep: Reputation: 15
Quote:
Originally Posted by alpartis View Post
Had the same problem ... spent the better part of a day trying to work through it. For me, the error message set me up for failure by leading me down the wrong path looking for a solution. The real underlying problem was directory permissions two directories above in the path.

Be sure the entire path has at least golbal 'read' permissions set!

A quick 'chmod 755 dir' solved the problem for me. Zounds!

-ap
ap,
thank you, Thank You, THANK YOU,

I've been racking my brain over this for the past 2 days: http://ubuntuforums.org/showthread.p...68#post6335168

and your post here solved my problem.
Thanks,
-BassKozz
 
Old 04-27-2009, 12:20 PM   #9
dkrysak
LQ Newbie
 
Registered: Sep 2004
Distribution: centos
Posts: 25

Rep: Reputation: 15
Quote:
Originally Posted by alpartis View Post
Had the same problem ... spent the better part of a day trying to work through it. For me, the error message set me up for failure by leading me down the wrong path looking for a solution. The real underlying problem was directory permissions two directories above in the path.

Be sure the entire path has at least golbal 'read' permissions set!

A quick 'chmod 755 dir' solved the problem for me. Zounds!

-ap
OMG, this issue was killing me until i saw this thread!
 
Old 07-05-2010, 07:53 AM   #10
Xolture
LQ Newbie
 
Registered: Jul 2010
Posts: 1

Rep: Reputation: 0
Thumbs up Thank You

I had similar problem and it was killing me for almost a week. Thanks to you "alpartis" now that those stressful days are finally over.
 
Old 07-25-2010, 06:05 AM   #11
ahmader
LQ Newbie
 
Registered: Jul 2010
Posts: 1

Rep: Reputation: 0
I had similar problem : NT_STATUS_BAD_NETWORK_NAME
and after couple of hours I have found that my path was incorrect due Caps letters, keep in mind paths name should be case sensitive even if you are browsing the windows folders in short the administrive share of the entire partion c should be accessed

//xxx.xxx.xxx.xxx/C$

not

//xxx.xxx.xxx.xxx/c$
 
Old 08-23-2010, 06:43 PM   #12
ambicapathy1982
LQ Newbie
 
Registered: Aug 2010
Posts: 2

Rep: Reputation: 0
Thumbs up tree connect failed: NT_STATUS_BAD_NETWORK_NAME

Resolution
----------

Hello everyone this error occurs due the share name given in the smb.conf file.

If you are trying to share a folder called "ambi_test", then in the configuration file the entries should as below.

[ambi_test] //THIS IS THE PART FOR THIS ERROR USUALLY AND ALSO THIS IS CASE SENSITIVE

comment = Ambi Share folder
writable = yes
create mode = 0770
directory mode = 0770
share modes = yes
guest ok = no // guest not allowed


*******Thank me if your issue is resolved****************

Last edited by ambicapathy1982; 08-23-2010 at 06:45 PM. Reason: correction in valid users section
 
Old 09-19-2010, 08:21 PM   #13
raspino
Member
 
Registered: Jul 2010
Posts: 38

Rep: Reputation: 0
step by step instructions

Can someone please give step by step instructions on how to solve this problem with permissions? I am having the same problem but not sure how to solve the problem
 
Old 02-14-2011, 03:29 AM   #14
mrechte
LQ Newbie
 
Registered: Jul 2005
Posts: 12

Rep: Reputation: 0
Hello,

I was faced with this problem too, but the cause was different. On RedHat / Fedora products, SELinux is enabled and enforced by default. Disabling it solved this issue (/etc/sysconfig/selinux).

Regards
 
Old 03-07-2011, 10:38 PM   #15
neonate
LQ Newbie
 
Registered: Mar 2011
Posts: 10

Rep: Reputation: 0
Smile tree connect failed: NT_STATUS_BAD_NETWORK_NAME

im also having the same problem as: tree connect failed: NT_STATUS_BAD_NETWORK_NAME
when i tried to browse the shared samba directory.

the directry is shared in this way
[nfshare]
comment = nfsshared directory with samba
path = /nfstest
public = yes
writable = yes
printable = no
write list = john smith
valid users = john smith
hosts allow = 192.168.4.
hosts deny = 192.168.4.50

I did boolean on as :

[root@station51 ~]# getsebool -a |grep samba
samba_domain_controller --> off
samba_enable_home_dirs --> on
samba_export_all_ro --> on
samba_export_all_rw --> on
samba_share_nfs --> on
use_samba_home_dirs --> off
virt_use_samba --> off

what is the problem, im getting alot confusion.
plz help me out of this. This deny host from samba is correct? is there any other method to deny any specified host in samba.


thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
smbmount - tree connect failed m.b Linux - Networking 6 09-27-2006 12:44 PM
tree connect failed: NT_STATUS_BAD_NETWORK_NAME lostboy Linux - Networking 5 09-03-2004 07:44 AM
Samba problem..-tree connect failed.. cobrichka Red Hat 2 01-04-2004 12:00 PM
tree connect failed: Adibe_Hamm Linux - Networking 0 09-16-2003 07:13 AM
tree connect failed: ERRDOS -ERRnosuchshare Randall Linux - Networking 2 02-09-2002 06:10 PM


All times are GMT -5. The time now is 08:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration