-   Linux - Networking (
-   -   traceroute - help? (

ocset 09-05-2004 03:25 PM

traceroute - help?
I am using traceroute for the first time and having no success and need some help. The output from traceroute is basically

traceroute to www .google. com (, 30 hops max, 40 byte packets
1 0.497 ms 0.506 ms 0.596 ms
2 * * *
3 * * *
4 * * *
5 * * *
6 * * *
7 * * *

My network is setup using a standard Ethernet card on my SUSE 9.1 machine connected to a Netgear DG814 ADSL Modem/router. I am using DHCP for IP address allocation and using bog standard BT broadband with a dynamic IP address.

Is it my config or is something else amiss

I have no problem connecting to the Internet and was looking at traceroute purely from a learning perspective and not to solve a current network issue.

ps. I have also tried xtraceroute with the same result


Mara 09-05-2004 03:50 PM

Traceroute may be blocked in your network. Does ping work (ping Probably both ping and traceroute are blocked. Or it may be just your own firewall, if you have one.

ocset 09-05-2004 06:40 PM


Ping works fine.

PING www. google. akadns. net ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=240 time=45.1 ms
64 bytes from icmp_seq=2 ttl=240 time=44.2 ms
64 bytes from icmp_seq=3 ttl=240 time=44.1 ms

zatriz 09-05-2004 10:30 PM

Because the first route outside works fine it has nothing to do with traceroute being blocked on your end.
Read up on what traceroute does it may help you.

What happening is that there is a time allocation for how long a router has to respond some routers are busier than others.
by default i believe trace route will wait 5 seconds before sending out the next packet mean one of three things if the resulting router did not respond.

1.) A router on the path not sending back the ICMP "time exceeded" messages

2.) A router or firewall in the path blocking the ICMP "time exceeded" messages

3.) The target IP address not responding

Routers can be configured to do this because it makes for less load on the routers.
so just dont worry about it there is nothing wrong with your network.

ocset 09-06-2004 04:36 AM

I trawled the web for any more clues and it seems that it is the UDP protocol that could be to blame. traceroute on Linux uses UDP by default while tracert on windows uses ICMP by default.

I ran tracert on my windows machine and it works.

Only problem I have now is trying to get traceroute to use ICMP instead of UDP.

none of these iterations work
traceroute -I
traceroute -I ICMP
traceroute -I icmp

Thanks for your help

zoroirooni 10-14-2004 11:41 PM

Hi all,

I have encountered the same problem described above by Ocset.

Is there a way to change UDP to ICMP in xtraceroute?


zatriz 10-15-2004 04:34 PM

I dont see why traceroute -I <destination> shouldn't work because then it switches to icmp packets
but you can also try this program tcptraceroute its seems to be pretty good at gettings past most firewalls.

All times are GMT -5. The time now is 05:10 AM.