LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Toshiba Satellite, Netgear MA401, Redhat 9 = NOT WORKING UGHGHGH!!!!! (https://www.linuxquestions.org/questions/linux-networking-3/toshiba-satellite-netgear-ma401-redhat-9-%3D-not-working-ughghgh-84791/)

chopinpatel 08-23-2003 02:32 AM

Toshiba Satellite, Netgear MA401, Redhat 9 = NOT WORKING UGHGHGH!!!!!
 
Ok Guys,
I have tried to do all the search possible, and I haven't got a clue. I read quite a bit of messages posted by others but I don't understand what is going on with my system.

I have a Toshiba Satellite (1115-S103), Netgear MA401 Wireless PCMCIA card, using on RedHat 9. Ok all I want to do is surf the web via my wireless card. How hard can this be, apparently very hard on Linux.

First of all when click on "RedHat" (Start button), then go to "System Tools" and "Network Device Control". When I try to add my wireless card, obviously there is no "Netgear MA401". After doing some research, people say it uses "Orinoco" drivers or something. Can some first tell me which card I should even try to attempt to use instead of Netgear MA401.

I have tried picking Orinoco card, and few others, however I haven't found any luck. Believe me I did not want to harrass you guys at all. But so frustrated don't know what to do.......

Get this, I don't think PCMCIA is working at all, because when the laptop is booting up, it has errors on "No IRQ Known" many people have also seen this. I tried to login as root and edit "/etc/sysconfig/pcmcia" and changed the setting from "Yenta_socket" to "i823...." something something.... that didn't work either.

Can someone please tell me step by step how to get this SH** started. I am so frustrated can't even tell you. Thousand thanks upfront.... may you live a million years...

Thank You.

P.S: Please excuse my typooooosss..........

farzadb 08-23-2003 11:28 AM

Make sure your laptop PCMCIA controller is set to PCIC Compatable mode in the BIOS

chopinpatel 08-23-2003 05:22 PM

I can't, there aren't any settings related to PCMCIA in the BIOS. I just looked at it right now.

Anything else I can do besides that.

Thanks.

farzadb 08-23-2003 08:30 PM

Doing a little googling on your particular laptop. It seems that "This laptop is of a type known as "legacy free" meaning it doesn't have a BIOS like other PCs. Instead of a BIOS it uses the newer, but poorly supported, ACPI (Advanced Configuratoin and Power Interface) to control access to many peripherals and PCMCIA is one feature that simply won't work without ACPI support" (according to
home.gagme.com/greg/linux/toshiba1115-rh9.php - I'm sorry I can't post a proper URL since the system complains that I don't have enough points). The link mentioned goes into detail on how to setup ACPI and other devices on the laptop.

Once ACPI is configured, the correct driver (if your system doesn't automatically pick it up) is the prismII.

Hope this helps.


-- Farzad

capedc 10-06-2003 09:54 PM

is it just this laptop or others as well hp4420us

mwolff 10-20-2003 01:26 AM

I have that same card but,
 
I have that same card on a different laptop with RH 9 and am having slightly different problems that I have been struggling with.
On my laptop, it seems like the card only half works, for example, I was able to once get onto the net and it is able to pick up AP's. However, I cannot seem to activate the device in Redhat Network Config. During startup of RH9 the error "Channel out of range eth(0)!" is posted.

Any ideas?

Thanks,
Martin

farzadb 10-21-2003 06:28 AM

mwolff,

It sounds like your card is setup for a particular set of frequencies (ie. for a particular country) however, it looks like RH is trying to force a different set of frequencies, possibly US frequencies, thus the Channel out of range error.

I'm not sure if there are any tools on Linux to modify the channel frequencies (I haven't seen any), however, if you have access to a Windows laptop, you could try change the country type there and then boot into Linux and see what happens.

Just a thought...


All times are GMT -5. The time now is 05:14 PM.