-   Linux - Networking (
-   -   Tight VNC Slackware can only login as root (

Alinuxnoob 09-08-2004 05:42 PM

Tight VNC Slackware can only login as root
OK my PC is on @ home login as root, but I was wondering why I can't login as a user.....
I ssh into my linux box as the user
and then I start vncserver :2
and then I enter the ip address and said "failed to connect to server"

Is that because my PC is login in as user @ home or it doesn't make a difference?

and each time I start vncserver I get this
"Couldn't start Xvnc; trying default font path.
Please set correct fontPath in the vncserver script."

"New 'X' desktop is OnlySecure:1

Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/OnlySecure:1.log"

and this is my my script....

exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
startkde &

Alinuxnoob 09-10-2004 03:25 PM


Alinuxnoob 09-10-2004 05:57 PM

Ok I got more info now

I login as a user and then I startup vncserver using this user and then I get this error

couldn't find "xauth" on your PATH

need help don't know what to do

Alinuxnoob 09-10-2004 06:07 PM

Fixed it just had to run xauth

loadedmind 01-09-2005 01:18 AM

RE: xauth
Hi. I have the exact same problem, but when you stated that you fixed the problem with xauth, you didn't state what arguments you used with it to get it to work. I'd appreciate it greatly if you would please give the steps/switches you used with xauth to get it to work.


Cedrik 01-09-2005 02:24 PM

add these lines in the script :


if ! which xauth > /dev/null 2>&1; then
    export PATH="$PATH:/usr/X11R6/bin"

loadedmind 01-09-2005 06:01 PM

RE: Script
Which script to I add those lines to and anywhere in that script will do? I tried adding it to the end of the vncserver script, but it had no effect on the error message. Thanks ahead of time.


loadedmind 04-05-2005 03:37 PM


All times are GMT -5. The time now is 04:51 PM.