-   Linux - Networking (
-   -   System hang on network card init (

av2zeal 07-20-2008 10:24 PM

System hang on network card init
I figured that I would post here, as in the process of learning linux and googling answers to problems that I have had, 99% of the answers came from here. People here just seem to know what they're talking about. I've tried to research an answer to this problem and have thus far been unsuccessful. I decided to take the plunge and make my own post. So, here goes....

I followed the instructions on the forums @ www (dot) killernic (dot) com and everything seemed to work fine at first, but now every time I boot up, I get this error:


------------[ cut here ]------------
kernel BUG at include/linux/timer.h:145!
invalid opcode: 0000 [#1] SMP
Modules linked in: pcmcia pcmcia_core lp parport_pc parport fuse fan nvidia(P) joydev thermal rtc_cmos serio_raw killer_driver rtc_core agpgart i2c_nforce2 button rtc_lib psmouse forcedeth evdev processor sg

Pid: 2938, comm: ifconfig Tainted: P        ( #2)
EIP: 0060:[<f8e9975e>] EFLAGS: 00010286 CPU: 1
EIP is at killer_open+0x2fe/0x310 [killer_driver]
EAX: f73be4d4 EBX: 00000000 ECX: 00000292 EDX: c0967f44
ESI: 00000002 EDI: f73be480 EBP: 00000080 ESP: f71a3e84
 DS: 007b ES: 007b FS:00d8 GS: 0033 SS: 0068
Process ifconfig (pid: 2938, ti=f71a2000 task=f7435a90 task.ti=f71a2000
Stack: f73be000 f73be000 00000000 00000000 00000400 00000400 4882955c 000d4f24
      f73be000 00001043 00001002 00000000 c0668990 f73be000 c06674e2 f73be000
      f71a3f10 c0665e64 f71a3f10 f71b510c f71b510c 00008914 c06b0aa5 00000000
Call Trace:
 [<c0668990>] dev_open+0x50/0x80
 [<c06674e2>] dev_change_flags+0x82/0x190
 [<c0665e64>] __dev_get_by_name+0x74/0x90
 [<c06b0aa5>] devinet_ioctl+0x505/0x690
 [<c0668632>] dev_ioctl+0x292/0x530
 [<c065a72f>] sock_ioctl+0xcf/0x220
 [<c065a660>] sock_ioctl+0x0/0x220
 [<c018465b>] do_ioctl+0x2b/0x90
 [<c01848ee>] vfs_ioctl+0x22e/0x2b0
 [<c01849c6>] sys_ioctl+0x56/0x70
 [<c0184336>] syscall_call+0x7/0xb
 [<c06e0000>] svcauth_unix_set_client+0x100/0x180
Code: 0c 6a a0 e9 f8 c7 44 24 08 19 00 00 00 c7 44 24 04 a8 a0 e9 f8 c7 04 24 c5 a0 e9 f8 e8 cc 0a 29 c7 e8 77 cf 26 c7 e9 07 fe ff ff <0f> 0b eb fe 8d bc 27 00 00 00 00 53 89 c3
EIP: [<f8e9975e>] killer_open+0x2fe/0x310 [killer_driver] SS:ESP 0068:f71a3e84
---[ end trace 5f58e87de8594216 ]---

I'm fairly new to Linux and I'm running Slackware 12.1 with a kernel. Any help would be appreciated.

The killer nic still works fine under winxp, so it's not a mounting issue. I also edited /etc/rc.d/rc.inet1.conf and if I remove the ipaddress/subnet mask assigning, then the kernel init goes fine. But as soon as I try to assign the card an ip address, either static or through DHCP, the system freezes.


MS3FGX 07-21-2008 02:51 PM

Well, what is happening is that the KillerNic driver is crashing the kernel when you try to bring the interface up. It is hard to say as there is no documentation at all with the Linux KN driver, but given it's age, I am going to assume that it is no longer compatible with recent kernels. You may need to try building it against an older kernel release.

av2zeal 07-21-2008 04:39 PM

First off, thanks for the reply. When I first tried to compile the killer_driver module, I was using the old src code, and like you said, it wouldn't compile with the newer kernels. I browsed their forums and found the Linux community forums and found a link to the newer builds: www (dot) killernic (dot) com/KillerForums/showthread.php?t=2047 . I was then able to compile the module for the newer kernels. The module actually worked for a while and I was able to access the internet. But upon reboot, I now get this error. I was hoping that someone would be able to decipher the error and tell me if there is something else that I could check... if not, I maybe doing a clean install to see if I get the same problem again.


av2zeal 07-22-2008 12:48 PM

Just an update... I reflashed the card and it worked for the first boot, but upon rebooting the system, I get the same error again. Buggy linux module? Bad initialization? What I don't understand is how it can work perfectly, and then not work at all after a reboot? I'm dual-booting off of seperate HDs and the card works fine under winxp. :( Please help me escape the grasp of M$.


All times are GMT -5. The time now is 12:18 AM.