LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-17-2002, 11:24 AM   #1
themorph
LQ Newbie
 
Registered: Feb 2002
Location: Kiel / Germany
Distribution: RedHat 7.2
Posts: 10

Rep: Reputation: 0
SWAT does not work when calling localhost:901


I can't use swat, and have no idea why...
the only thing is, when I am pinging localhost
or the static ip i get the message:
OPERATION NOT PERMITTED

But when I ping from a windows client, i am getting an answer
 
Old 03-05-2002, 06:06 PM   #2
desbyleo
Member
 
Registered: Feb 2002
Location: Erie, CO
Distribution: Red Hat 7.1
Posts: 94

Rep: Reputation: 15
I am also trying to do this...

I think you need swat running and httpd.

If you log in as root...go into GNOME (this is the only way I know haow to do this) go to;

foot>programs>system>text mode tool menu

In the the System Services, turn on swat and httpd.

Then you need to have an entry in your inetd.conf or xinetd.conf (found in /etc). The entry looks like this:

swat stream tcp nowait.400 root /usr/sbin/swat swat

You might do a "$locate swat" to find the actual path.

I'm a newbie too, but so far I have gotten it to work along with SAMBA with these simple steps and others concerning config od SAMBA. Go to linux.com for full article on setting up samba.
 
Old 03-06-2002, 11:04 PM   #3
ryandelany
Member
 
Registered: Dec 2001
Location: Orange County, CA
Distribution: RedHat 7.2, 7.3, 8.0
Posts: 66

Rep: Reputation: 15
Follow these steps to install SWAT:

Install Swat from the RPM

Make sure this line exists in /etc/xinetd.d/swat

disable = no

Also modify this line to include the IP address of the machine you are connecting from: (example assumes 192.168.1.1)

only_from = 127.0.0.1 192.168.1.1

Verify that the following line is uncommented in /etc/services

swat 901/tcp

Add the following entry to /etc/hosts.allow

swat: ALL

Restart the xinetd service with this command:

service xinetd restart

Navigate to the following URL in your browser:

http://<ip address>:901

Enter your username and password, and you should be able to configure Samba.

Ryan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SWAT cannot connect to localhost port 901 KhmerDucky Linux - Networking 2 02-09-2020 03:58 PM
Problems with Samba: http://localhost:901 doesn't work lagu2653 Linux - Networking 5 06-29-2005 03:13 PM
Samba - Swat: Cannot Connect to Localhost:901 Sloppyunderfoot Linux - Networking 3 02-10-2005 12:26 PM
SAMBA & SWAT - Connection refused when attempting to connect Localhost:901 ScooterB Linux - Networking 3 12-24-2003 04:15 PM
Errors on accessing Swat SAMBA http://localhost:901 @ Mandrake 9.0. Zepiroth Linux - Networking 2 06-03-2003 09:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration