LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   swat does not run? (https://www.linuxquestions.org/questions/linux-networking-3/swat-does-not-run-34449/)

emin 11-02-2002 06:31 PM

swat does not run?
 
hi,

I have installed samba, and all changinh made, so as explained in instructions from swat, and I wrote in explorer http://localhost:901 and comes nothing...

what should I do??

mwjcox 11-02-2002 10:15 PM

Be sure that you have the swat server running with /sbin/service swat restart in Redhat.

rohang 11-03-2002 05:37 PM

Is swat enabled? Check in /etc/xinetd.d and look at your swat file. To enable it, it should look something like this:

# default: off
# description: SWAT is the Samba Web Admin Tool. Use swat \
# to configure your Samba server. To use SWAT, \
# connect to port 901 with your favorite web browser.
service swat
{
port = 901
socket_type = stream
wait = no
only_from = 127.0.0.1
user = root
server = /usr/sbin/swat
log_on_failure += USERID
disable = no
}

emin 11-04-2002 09:08 AM

now it does run...
 
hi again,

you have right.. now everything is allright..


Thanks..

Emin

disayas 11-26-2002 02:02 AM

Hey I have a similar problem. I used the RH update agent to install Samba 2.2.7 which has SWAT. When I check to see if Samba is running using rpm -q samba it shows me 2.2.7 but I can't find any swat files and I don't find Samba in /usr/local.

Any suggestings?

thanks...

ramki 12-24-2002 08:48 AM

Iam also unable to start swat

I have installed Redhat Linux7.2 on Mainframe ( Z900 )

I don't have inetd.conf file

I only have xinetd service running

Can someone please help troubleshoot this problem ?

Iam trying to start swat from the network meaning
Iam telneting to the Linux server.

jose_bravo 12-26-2002 02:16 PM

ramki,

Version 7.0 and on of Red Hat uses a couple of different mechanisms in using SWAT (which I learned the hard way, being so used to 6.x :)). Make sure you have SWAT set up in your /etc services file by having this line there and uncommented:

swat 901/tcp

Second, for various reasons, Red Hat now uses xinetd rather than inetd that were all used to. Create a file (if it's not there already called swat in the /etc/xinetd.d/ directory. Type the following in:

service swat
{
port = 901
socket_type = stream
wait = no
user = root
server = /usr/local/samba/bin/swat
log_on_failure += USERID
disable = no
}

and finally, Red Hat (and SWAT) uses PAM for authentication. Make sure that the /etc/pam.d/samba file exists and that it contains the following:

auth required /lib/security/pam_pwdb.so nullok shadow
account required /lib/security/pam_pwdb.so

Restart xinetd with a <b>killall -HUP xinetd</b>, access the site through <b>http://localhost:901</b> and you should be ready to go!!! Good luck!!!

ramki 12-27-2002 02:50 AM

Thanks a lot Jose bravo
 
Thanks a lot.

But now I have problem setting up shares in samba for
folders.


All times are GMT -5. The time now is 04:22 AM.