LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   suse 9.1 and IPv6 (https://www.linuxquestions.org/questions/linux-networking-3/suse-9-1-and-ipv6-276207/)

rafusmx 01-10-2005 02:56 PM

suse 9.1 and IPv6
 
Hello!

I've been playing with some hybrid IPv6-IPv4 networks, but I've some trouble setting up the routing tables on a Suse9.1 box. I had already tried with the classic manual configuration using "route" and "ip" but none of them seems to work fine. I'm tried the same options on two Debian PCs, but I don't had any touble with them.

When configuring Suse I get:

# route -A inet6 add ::/0 gw 1212::12:12:12:12:1 dev eth0
SIOCADDRT: Invalid argument

# ip -6 route add ::/0 via 1212::12:12:12:12:1 dev eht0
RTNETLINK answers: Invalid argument

:confused:

Well... see you later!

rafusmx 01-11-2005 01:23 PM

mmm... I think I found part of the answer.

The problem is that the kernel routing table has write protection on it. And (as if Suse needs another reason to be on my don't-like-it list) you should not be able to change the file attributes using old good chmod...

I'll publish the same question on another post, but does anyone knows who in this world should be able to make changes in Suse system files if root can't? Is there some kind of "realroot" or something like that?


:mad: :mad: :mad:


All times are GMT -5. The time now is 06:03 PM.