LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-22-2011, 07:36 PM   #1
dtinazzi
LQ Newbie
 
Registered: Sep 2009
Posts: 4

Rep: Reputation: 0
Strange situation: network gatewayed, then proxied


Hi all experts,

I've a strange situation in my network: pcs gatewayed to another network, then a proxy, then a firewall.

pcs --> router --> cloud --> router --> proxy --> switch <-- fw --> Internet

(router, proxy and fw are alla connected by the switch)

Some months ago the situation was :

pcs --> router --> cloud --> router --> switch <-- fw --> Internet

There was a static route in the router that gatewayed the packets to the firewall, but that route has been deleted, and I cannot reinsert it because I've not access to the routers, so we have to use a proxy to go to Internet, and we have the configuration of all pcs (Windows XP) with the fields "proxy" filled.
The proxy ha only one NIC gatewayed to the firewall, and Ubuntu and squid installed, but we have some problems:
1. we cannot use email, so how can we make port 110 and 25 packets pass?
2. squid seems to slow down, so can we uninstall it and route all the traffic directly to the firewall to speed up?

Thanks
Dario
 
Old 02-23-2011, 07:16 AM   #2
besolius
LQ Newbie
 
Registered: Feb 2011
Posts: 13

Rep: Reputation: 1
there seems to some problem with the squid...if it is intended to cache the browsing then it is not going to interfere with the mail...the problem could be the firewall...ask if it is blocking those ports.
 
Old 02-23-2011, 04:48 PM   #3
dtinazzi
LQ Newbie
 
Registered: Sep 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Hi besolius,

the firewall was tha same used when we had not to use the proxy, programmed in the same manner, and we had not problems with email.
The problems started when we had to put the proxy between...

Dario
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Two network interfaces on Ubuntu 10.4.1 caused strange network problem iArash Linux - Networking 1 02-06-2011 05:07 AM
Accessing port 6886 through proxied port 80 system Boffy Linux - Server 4 05-04-2008 08:13 AM
mod_rewrite for rewriting proxied path GSMD Linux - Server 0 02-28-2007 09:01 AM
strange situation with totem(radeon9200se+mdk10.1) Filmoscope Linux - Hardware 0 05-13-2005 01:57 AM
strange network problem kmoallem *BSD 3 02-04-2003 01:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration