-   Linux - Networking (
-   -   Strange problem, both samba and NFS (

gwroy20 05-24-2003 12:20 PM

Strange problem, both samba and NFS
I'm having a weird problem. I've got a file server set up with samba and NFS, it's been working fine since I installed it. But all of a sudden I can only mount shares as read-only on my client computers running Linux. When I mount the shares with samba, I have read/write permission as root, but not as a user and when I mount the share with NFS I have no write permission at all.

The odd thing is that I can log into it fine with full read/write access while running Windows. I dual-boot windows and linux on both my laptop and my main desktop, the above-mentioned problems only exist when I'm running linux.

WTF :scratch:

david_ross 05-24-2003 01:56 PM

Have you changed anything lately? Perhaps entries in /etc/fstab?

gwroy20 05-24-2003 02:27 PM

Nothing major, I have about 8 partitions in the server that I had entries for in /usr/pub with full permissions for my network, it's been working fine since installation. I added some more entries in fstab pointing to the same partitions, but mounted in a different directory so I could give them permissions more suitable to an FTP server.

I figured that might have been the problem at first, but I commented out all the lines in fstab pointing to the second directory. I don't think that had anything to do with it now.

gwroy20 05-25-2003 03:07 PM

I finally gave up and just reinstalled Slackware on the file server, same problem. Any ideas at all?

bastard23 05-25-2003 04:20 PM


Did the IP address change (DHCP or something)? Is it different that when it boots windows? Maybe post your /etc/exports and any errors in the logfile. Make sure to copy and paste as exports is really sensitive to whitespace.

Good Luck,

gwroy20 05-25-2003 04:44 PM

My /etc/exports only has one line, it's


The IP addresses are all the same, they are static. And all the computers that dual boot use the same IP address in Linux and Windows. Everything I've tried so far seems to point to it being a problem with the actual mounted partitions, permissions maybe. But I can't imagine what, one day it all worked the next it didn't.

xfree143 05-26-2003 05:21 AM

had the same thing
I have had the same thing happen, but it was with all my win work stations. Even though all the dir. showed as having the correct user permisions I had to create a new group and add all the users to it and the give that group permision to the dir.'s I wanted them to have access. Why it worked for weeks and then just stoped I will never know!

gwroy20 05-26-2003 03:09 PM

Now I've got a real problem. I halted the machine like normal last night and when I booted it up today, right at the point where Lilo should have come up I got an endless string of 40's printing to the screen. I rebooted it with the startup disk and got in ok. I figured reinstalling Lilo might fix the problem, but when I went to reinstall it, I got an error message saying that there were syntax errors in lilo.conf. When I edited lilo.conf, there were random areas missing. For example, it would say "root = " instead of root = /dev/hde and the vga = section was gone. The wierdest thing is that before I could finish editing it back to normal, the computer just rebooted itself. It did this several times until I finally was able to reinstall lilo. Then when I did reinstall lilo, I now get the old "Kernel Panic: unable to boot root filesystem" error. wtf is up with this computer

david_ross 05-26-2003 03:19 PM

I would try running fsck on your HDD to see if there are any disk faults first. What filesystem are you using?

gwroy20 05-26-2003 03:33 PM

I'm using ext3 on all my partitions

I'm getting ready to reinstall again, this time I will format with error checking.

gwroy20 05-26-2003 04:27 PM

Ok, I'm really at a loss now. I reinstalled, everything went fine. Started up on the first boot and started configuring my system, computer rebooted itself ......

david_ross 05-26-2003 04:33 PM

1) Not on a UPS - ie a power failure
2) Dodgy PSU
3) Dodgy MotherBoard
4) Something else :D

gwroy20 05-26-2003 06:57 PM

No chance it's a power failure, not too sure what a PSU is, and I'm doubting that the motherboard is the culprit. Im leaning more towards possibility number 4.

The reason I doubt a motherboard failure is because the computer runs fine during setup, i've tried reinstalling slack several different times with different options (even tried installing older version) and it runs through it fine. But when I boot the computer up after installation, it lasts a minute tops before it reboots.

Has anyone ever had a similar experience?? Next thing I'm going to try is installing RedHat and seeing if there's any difference

david_ross 05-27-2003 12:31 PM

The PSU is your power supply unit. Take a look at the:

file and see if there are any funny looking messages just before the reboot. You may also want to try brinign it up in single user mode and see if it lasts any longer.

gwroy20 05-27-2003 02:45 PM

Ok thanks, will do. By the way, I installed Windows XP to see if there'd be any difference. It was up for over an hour, but when I installed Slackware again....same thing.

All times are GMT -5. The time now is 03:18 PM.