LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Strange 1 GbE PC to PC Cross-Cable Problem (https://www.linuxquestions.org/questions/linux-networking-3/strange-1-gbe-pc-to-pc-cross-cable-problem-430596/)

LinuxGeek 04-01-2006 07:05 AM

Strange 1 GbE PC to PC Cross-Cable Problem
 
Hi,
I just purchased 2 RealTek 8169 1GbE NICs which I plan on using to connect 2 PCs back to back [without a switch]. So I put one in each PC. RHEL v4 saw them and asked me to configure them (IP, etc.) which I did. However, when I come to attach them via a cross-over cable, neither one can see the other. When I force autonegotiation off and set the speed to 100 using ethtool:

ethtool -s eth1 autoneg off speed 100

they can see each other and I can ping from one to the other. However, when I try to set it to 1000 instead of 100 (on both PCs), neither PC can see the other. Do you have any ideas? Thank you for your help.

PS. lspci -vv shows the following:

02:04.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
Subsystem: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 64 (8000ns min, 16000ns max), Cache Line Size 08
Interrupt: pin A routed to IRQ 201
Region 0: I/O ports at dc00 [size=256]
Region 1: Memory at fddfe000 (32-bit, non-prefetchable) [size=256]
Capabilities: [dc] Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0-,D1+,D2+,D3hot+,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-

okmyx 04-01-2006 08:12 AM

You can't do it because its not possible with standard cross over cables (see link), something i didn't know until i saw the link.

http://logout.sh/computers/net/gigabit/

Basically its because 1GbE over copper uses all for pairs, where as 100BaseTX only uses 2. What you need is a CAT6 cross over cable (wireing diagram is in the link).

LinuxGeek 04-01-2006 08:51 AM

Thanks okmyx. I'll try to get my hands on a CAT6 and test it out.

LinuxGeek 04-02-2006 12:39 PM

I just purchased a CAT6 cable and it still doesn't work. I even tried installing the latest version of the drivers from Realtek's site but it still wouldn't negotiate to 1000. Any ideas? Do I have to modify the CAT6 cable in any way? Thanks for your help.

okmyx 04-03-2006 04:19 AM

You will need a cross-over CAT 6 cable (if they do such a thing)

LinuxGeek 04-03-2006 04:24 AM

I tried it with a cross-over CAT 6 cable. I even tried to connect it with a straight CAT 6 cable to a 1GbE switch but it still negotiates at 100 Mbps :(


All times are GMT -5. The time now is 11:19 PM.