LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-21-2015, 12:49 PM   #1
jackcf
LQ Newbie
 
Registered: Oct 2015
Posts: 13

Rep: Reputation: Disabled
ssh Now Behaving Differently After New Install


Just installed a newer Linux (F22) replacing my older system (F19) which crashed.

I used to be able to remote login to Linux from my iMac with this command:

Code:
ssh -X -l xxx.xxx.xxx.xxx ralph
That now doesn't work but this does:

Code:
ssh xxx.xxx.xxx.xxx
Why would this change from the old to the new install?

Note I do need the -X option for the X forwarding. So what do I need to do to get the ssh to work with the -X and -l options?
 
Old 10-21-2015, 01:02 PM   #2
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,680

Rep: Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373
You probably just need to enable X11 forwarding on the server system to get the -X option to work, though it would help if you let us know whether you saw any errors.
For the -l option it's not something I have used, preferring to use the username@192.168.1.1 form, so sorry I can't be of any help there.
 
Old 10-21-2015, 01:24 PM   #3
Doug G
Member
 
Registered: Jul 2013
Posts: 749

Rep: Reputation: Disabled
Also, try putting the username directly after the -l switch, or use ralph@xxx.xxx.xxx.xxx and skip the -l
 
Old 10-21-2015, 02:22 PM   #4
jackcf
LQ Newbie
 
Registered: Oct 2015
Posts: 13

Original Poster
Rep: Reputation: Disabled
The X forwarding error is really a warning about unsecured forwarding. I got that mixed up with the error I got when I didn't use the -X option.

After going to the username@192.168.1.1 form every thing worked as expected. I will just use it that way since that follows the same form as scp which I also use a lot.

Thanks for the tips.
 
Old 10-21-2015, 02:37 PM   #5
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,680

Rep: Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373Reputation: 2373
I like the format with file managers also where one can just browse to:
Code:
sftp://username@192.168.1.1
Especially with key authentication it's (almost) transparent unless you're streaming full HD over wireless or something.
Edit: Don't forget to mark the thread as solved if things are now working.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Right and left shift keys started behaving differently and weirdly howdoI Linux - General 1 06-27-2015 02:28 PM
Different partitions of a drive behaving differently in Windows ravisingh1 Linux - Laptop and Netbook 4 05-16-2013 07:44 AM
Init script behaving differently when run on machines in the UK vs US BrianK Programming 6 07-21-2011 12:04 AM
Bash behaving differently jxrod2000 Linux - Software 2 10-06-2008 05:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration