-   Linux - Networking (
-   -   SSH not working after VPN Install (

nutcake 11-23-2005 12:53 PM

SSH not working after VPN Install

I've just rebooted a Debian server at work, and when it came back up, ssh didn't work.

I had been playing around trying to set various VPN packages up on this computer about a month ago and it hasn't been rebooted since. I have uninstalled and disabled the startup scripts for all these bits of software and I have now reinstalled ssh with stock config files.

SSH doesn't appear to be running when I do a 'ps aux', and nothing is listening on port 22 (if I do a netstat). I have tried changing to different ports and restarting the service, without success. However, the ssh startup script doesn't give any errors when staring or restarting and everything seems to be where it should.

I am in a bit of a panic here, because I'm leaving this company (and country) tomorrow and may need to provide a bit of remote support.

I would appreciate *any* suggestions!

stickman 11-23-2005 02:14 PM

What happens when you try to run sshd manually?

nutcake 11-23-2005 03:28 PM

Hmmm, I don't think I tried that. Will do so and get back with the answer tomrrow morning (UK time.)

Thanks for the idea :)

nutcake 11-24-2005 05:47 AM

Ok, tried it and it didn't give any errors, but didn't seem to start running either.

nutcake 11-24-2005 08:36 AM

Just tried running sshd -D (Didn't read things properly before trying last time) and sshd started fine and is accepting connections!

At least I am not in as much trouble as I thought now.

Does this mean that there is a problem with the init script? How could I replace it? Can I just delete it and the use apt-get to reinstall ssh?

Thanks again, stickman!

david_ross 11-24-2005 12:18 PM

Moved: This thread is more suitable in Networking and has been moved accordingly to help your thread/question get the exposure it deserves.

All times are GMT -5. The time now is 11:05 AM.