LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 03-22-2006, 06:23 AM   #1
thomas_fogh
LQ Newbie
 
Registered: Mar 2006
Location: Denmark
Distribution: Fedora, Ubuntu
Posts: 13

Rep: Reputation: 0
Question SSH login problem


I have trouble logging in using PuTTY.
I get the error "server unexpectedly closed network connection" when pressing <enter> after typing in the password.

My PuTTY setup is:
hostname = 192.168.0.40
port = 22
protocol = SSH
Connection->SSH->Auth = Attempt "keyboard-interactive" auth (SSH2)

and sshd_config:
Port 22
Protocol 2
ListenAddress 192.168.0.40
Subsystem sftp /usr/lib/misc/sftp-server
UsePAM yes

I tried starting sshd using sshd -d:
debug1: sshd version OpenSSH_3.8.1p1 Debian-8.sarge.4
debug1: read PEM private key done: type RSA
debug1: private host key: #0 type 1 RSA
debug1: read PEM private key done: type DSA
debug1: private host key: #1 type 2 DSA
debug1: Bind to port 22 on 192.168.0.40.
Server listening on 192.168.0.40 port 22.
debug1: Server will not fork when running in debugging mode.
Connection from 192.168.0.1 port 1340
debug1: Client protocol version 2.0; client software version PuTTY_Release_0.58
debug1: no match: PuTTY_Release_0.58
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.8.1p1 Debian-8.sarge.4
debug1: permanently_set_uid: 100/65534
debug1: list_hostkey_types: ssh-rsa,ssh-dss
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: client->server aes256-cbc hmac-sha1 none
debug1: kex: server->client aes256-cbc hmac-sha1 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST_OLD received
debug1: SSH2_MSG_KEX_DH_GEX_GROUP sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_INIT
debug1: SSH2_MSG_KEX_DH_GEX_REPLY sent
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: KEX done
debug1: userauth-request for user thomas service ssh-connection method none
debug1: attempt 0 failures 0
debug1: PAM: initializing for "thomas"
debug1: PAM: setting PAM_RHOST to "192.168.0.1"
debug1: PAM: setting PAM_TTY to "ssh"
Failed none for thomas from 192.168.0.1 port 1322 ssh2
Failed none for thomas from 192.168.0.1 port 1322 ssh2
debug1: userauth-request for user thomas service ssh-connection method keyboard-interactive
debug1: attempt 1 failures 1
debug1: keyboard-interactive devs
debug1: auth2_challenge: user=thomas devs=
debug1: kbdint_alloc: devices 'pam'
debug1: auth2_challenge_start: trying authentication method 'pam'
Postponed keyboard-interactive for thomas from 192.168.0.1 port 1322 ssh2
libgcc_s.so.1 must be installed for pthread_cancel to work
Postponed keyboard-interactive/pam for thomas from 192.168.0.1 port 1322 ssh2
colinux:/home/thomas# mm_request_send: write
debug1: do_cleanup
debug1: PAM: cleanup

I have no trouble loggin in locally using the account.
Anyone knows what's going on?
 
Old 03-22-2006, 09:33 AM   #2
jeanpd001
LQ Newbie
 
Registered: Aug 2004
Distribution: Redhat/Suse/Enterprise versions
Posts: 7

Rep: Reputation: 0
Have you got some form of firewalling enabled (iptables?) Check this first.

The fact that you can do a local SSH on the local machine prompts me to think you might have the ports blocked for outside machines.
 
Old 03-22-2006, 12:42 PM   #3
thomas_fogh
LQ Newbie
 
Registered: Mar 2006
Location: Denmark
Distribution: Fedora, Ubuntu
Posts: 13

Original Poster
Rep: Reputation: 0
Oh, sorry. I can't log in locally using SSH. I will get the same log output when using sshd -d when trying to log in locally using SSH.
What I meant was that I can log in normally using the account.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH Login problem Artik Linux - Networking 6 10-17-2005 09:54 AM
Another ssh login problem silver2003 Linux - Security 3 10-03-2004 08:44 AM
ssh login problem K_M_McMahon Linux - Newbie 4 03-29-2004 09:22 AM
SSH login problem - cannot choose user atom Linux - Networking 2 02-29-2004 11:53 AM
Strange! SSH and Telnet login problem McSmooth Linux - General 7 10-03-2003 09:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration