-   Linux - Networking (
-   -   SSH Login - Bypass public Key check (temp disable passwordless login) (

Lunar 02-22-2014 04:31 PM

SSH Login - Bypass public Key check (temp disable passwordless login)
I've search until I'm 'blue in the fingers'..
There is a lot of info on generating a key pair, uploading, configuring hosts etc.. But...

Here is my situation.
1) I have both id_dsa and id_rsa keys. Use one for GitHub other for Launchapd.
2) I can Login to them just fine, having copied my pub_key there.
3) the Problem is I also have a 'Reseller' (shared) web server at HostGator and I do not have root access on it.
4) Therefore, I can Not scp, or ssh-copy-id my Public Key to the Server's /.ssh/Autorize-whatever.
5) When I try and SSH into one of my Domains at HG, I am being Rejected, I assume because My KEY Does NOT match my 'cpanel' login user name (cpanel user is the same user, used for HG SSH login ('jailshell'))
6) If I temporarily re-name my ~/$HOME/.ssh directory to dot.ssh I can Login to my domain via SSH just fine.
7) the Question: How do I Bypass Key uses?
ie, How do I login as a plain user from console as if I did not have a private/public key?
8) There Has to be a way, because not all server have Key login or what if I just want to login to a clients server, just once to take a look around for them... I would Not want to go through the whole key generation, copy (upload) key routine... Right? !

9) This 'server' is mine, has been for 2 years and will remain 'mine' for the foreseeable future, so having a key would work and I would create a ~/.ssh/config file defining what key / login / server , but Again, I can Not copy the key to the 'shared' server.

10) # ssh -(NoKey_option_or_something) -p xxxx ?????? some command line option to bypass key check and Just use the information provided in this login line, for this session. ????

Thank You in advance,

unSpawn 02-23-2014 05:25 AM

Either pass the "PubkeyAuthentication no" option using "-o " on the command line or for a more permanent solution try something like this in your ~/.ssh/config:

Host whatever_provider_name
HostName whatever_machine_IPv4_address
Port 2222
User whatever_user_name
PasswordAuthentication yes
PreferredAuthentications password
PubkeyAuthentication no

*Note this isn't the way SSH should be used so please re-check the providers procedures to get pubkey auth enabled because I'm pretty sure they offer it.

All times are GMT -5. The time now is 11:46 PM.