-   Linux - Networking (
-   -   ssh connection closed immediately after logged in (

gqqnbig 07-02-2011 02:50 AM

ssh connection closed immediately after logged in
I'm using Ubuntu 11.04. I've bought an account in a SSH sever.


loveright 02:41:54 ~$ ssh gqqnb@
gqqnb@'s password:
Last login: Sat Jul  2 14:41:53 2011 from
Connection to closed.

I've tried many times, the issue persists. ssh localhost is ok.

I go to Windows, run Bitvise Tunnelier. After providing corresponding information, connection is established.


14:48:07.381 Starting a new SSH2 session.
14:48:07.383 Connecting to SSH2 server
14:48:07.594 Connected.
14:48:07.610 Starting first key exchange.
14:48:07.821 Server version string: SSH-2.0-OpenSSH_4.3
14:48:09.624 New host key received. Algorithm: ssh-rsa, Size: 2048 bits, MD5 Fingerprint: 23:9d:60:d8:2c:2c:32:42:20:7e:38:c0:c0:83:44:6c, Bubble-Babble: xiloz-vafen-zacab-vidif-samek-rydez-zisat-vifep-netop-duceg-fexax.
14:48:09.644 First key exchange completed.
14:48:09.648 Key exchange: diffie-hellman-group14-sha1. Session encryption: aes256-ctr, MAC: hmac-sha1, compression: none.
14:48:09.844 Attempting 'password' authentication.
14:48:11.096 Authentication completed.
14:48:11.096 Initializing SOCKS / HTTP CONNECT proxy on succeeded.

So, how can I fix? Any hints?

aysheaia 07-02-2011 03:45 AM

Try first a verbose connection :

ssh -vvv gqqnb@

gqqnbig 07-02-2011 03:48 AM

It's fixed now.
I contracted the custom service, he said it was because of the configuration of the server. He fixed it and I can log in successfully.

sysslack 07-02-2011 04:05 AM

try to debug. Type ssh -vvv gqqnb@ and check what difference in output
from Bitvise Tunnelier.

All times are GMT -5. The time now is 10:30 PM.