LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-03-2016, 02:06 AM   #1
evoolintend
LQ Newbie
 
Registered: Feb 2016
Posts: 3

Rep: Reputation: Disabled
Question Squid stop working,constantly freezes


0
down vote
favorite
I'm running Squid v. 3.3.11. I have around 150 active users. The machine physical resources are more than the recommended. I don't use the cache function, so it is turned off.

The problem is when I turn on the proxy after some days of work, it just freezes, I mean the client cant resolve any websites and I noticed little before the internet become very laggy before it crashes total and stop resolve websites. If I restart the service or the server the problem is solved for an, may be 10 minutes, then it just stops again. There is nothing in the cache.log .I've noticed that when it stops when I open /var/log/squid/access.log it writes in the log. Here is a part from the log file.

10.62.8.109 - - [19/Jan/2016:14:24:32 +0200] 200 0 TCP_MISS:HIER_DIRECT "CONNECT pollserver.lastpass.com:443 HTTP/1.1"
10.62.8.109 - - [19/Jan/2016:14:24:32 +0200] 200 0 TCP_MISS:HIER_DIRECT "CONNECT mtalk.google.com:443 HTTP/1.1"
10.62.8.109 - - [19/Jan/2016:14:25:06 +0200] 407 0 TCP_DENIED_ABORTED:HIER_NONE "GET http://www.data.bg/ HTTP/1.1"
10.62.8.109 - - [19/Jan/2016:14:25:06 +0200] 200 5239 TCP_MISS:HIER_DIRECT "CONNECT play.google.com:443 HTTP/1.1"
10.62.8.109 - - [19/Jan/2016:14:25:06 +0200] 200 1741 TCP_MISS:HIER_DIRECT "CONNECT plus.google.com:443 HTTP/1.1"
10.62.8.109 - - [19/Jan/2016:14:25:06 +0200] 200 5011 TCP_MISS:HIER_DIRECT "CONNECT play.google.com:443 HTTP/1.1"
10.62.8.109 - - [19/Jan/2016:14:25:16 +0200] 200 189800 TCP_MISS:HIER_DIRECT "CONNECT www.google.bg:443 HTTP/1.1"
10.62.8.109 - - [19/Jan/2016:14:25:16 +0200] 200 0 TCP_MISS:HIER_DIRECT "CONNECT ssl.gstatic.com:443 HTTP/1.1"
10.62.1.109 - - [19/Jan/2016:14:25:16 +0200] 200 0 TCP_MISS:HIER_DIRECT "CONNECT www.google.bg:443 HTTP/1.1"
10.62.1.109 - - [19/Jan/2016:14:25:16 +0200] 200 0 TCP_MISS:HIER_DIRECT "CONNECT www.google.bg:443 HTTP/1.1"
10.62.1.109 - - [19/Jan/2016:14:25:16 +0200] 200 0 TCP_MISS:HIER_DIRECT "CONNECT www.google.bg:443 HTTP/1.1"
What could be the reason for the crashes? I've checked the system resources nothing unusual I think.
 
Old 02-08-2016, 11:06 AM   #2
kirukan
Senior Member
 
Registered: Jun 2008
Location: Eelam
Distribution: Redhat, Solaris, Suse
Posts: 1,278

Rep: Reputation: 148Reputation: 148
Hi;
Just a curious, if you do not cache the content then why using squid? for authentication?
As per me the above logs is not sufficient to understand the issue, hope you can enable debug level log to understand more about the issue.

Regards
Raam.
 
Old 02-09-2016, 02:54 AM   #3
evoolintend
LQ Newbie
 
Registered: Feb 2016
Posts: 3

Original Poster
Rep: Reputation: Disabled
I use it for website restrictions in some parts of the day and also bandwidth restrictions for some users.SQUID auth with my AD.Where do you think is a good place to check for my problem.I also noticed that i cant ping websites from squid with ip v6 ping ,could it be a problem.Thank you.
 
Old 02-09-2016, 07:34 AM   #4
StanVokac
LQ Newbie
 
Registered: Feb 2016
Distribution: RedHat, CentOS, Debian + Solaris
Posts: 2

Rep: Reputation: Disabled
To see something more in logs you need to play with "debug_options" option.
http://www.squid-cache.org/Doc/config/debug_options/

Also check deeply system logs to avoid possibility that problem is caused by something else (laggy/failing network connection, DNS resolving etc).

Stan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Constantly Freezes: Remind Me Again Why Linux is Better johntabita Linux - Newbie 14 06-26-2012 09:25 PM
Toolbar constantly freezes adanedhel728 SUSE / openSUSE 1 03-08-2008 03:01 AM
Mandrake constantly freezes Him Mandriva 2 04-09-2005 09:28 AM
system constantly freezes phunkymunky Slackware 5 10-01-2003 11:41 AM
System constantly freezes danny678010 Linux - Hardware 8 02-07-2003 12:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration