LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 03-30-2009, 12:09 PM   #1
lucianosousa
LQ Newbie
 
Registered: Mar 2009
Distribution: Slackware
Posts: 3

Rep: Reputation: 0
Squid + squid_ldap_auth looping


my squid asks for user authentication, but when I type the username and password it loops back and asks ...
the command wbinfo-t is giving OK. any suggestions?

My squid.conf

“http_port 3128
icp_port 3128
hierarchy_stoplist cgi-bin ?
cache_mem 1500 MB
cache_swap_low 90
cache_swap_high 95
maximum_object_size 4096 KB
ipcache_size 1024
ipcache_low 90
ipcache_high 95
cache_dir ufs /usr/local/squid/cache 2500 16 256
cache_access_log /usr/local/squid/logs/access.log
pid_filename /usr/local/squid/logs/squid.pid
acl manager proto cache_object

logformat logluciano IP do cliente: %>a - Username: %un - Horario: [%tl] - Metodo: %rm - URL: %ru - Status HTTP: %Hs - Status Squid: %Ss - Porta: %>p
cache_access_log /usr/local/squid/logs/logteste.log logluciano
error_directory /usr/local/etc/squid/errors/Portuguese

acl localhost src 127.0.0.1/255.255.255.255
acl redelocal src 192.168.1.0/24
acl SSL_ports port 443 563
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 563 # https, snews
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl Safe_ports port 6959 #mirc
acl Safe_ports port 900 #mirc

auth_param basic program /usr/local/libexec/squid/squid_ldap_auth -v 3 -b ou=testnet,dc=domain,dc=local -DN=proxy_user,ou=testnet,dc=domain,dc=local -w -f sAMAccountName=%s -h ldap.domain.local

auth_param basic children 5
auth_param basic realm ProxyTest
auth_param basic credentialsttl 1 minute

acl password proxy_auth REQUIRED
http_access allow password

acl CONNECT method CONNECT

acl sites url_regex -i "/usr/local/etc/squid/sites.txt"
acl palavras url_regex -i "/usr/local/etc/squid/palavras.txt"
acl semcache url_regex -i "/usr/local/etc/squid/semcache.txt"

http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access deny sites
http_access deny palavras
http_access allow redelocal
no_cache deny semcache
icp_access allow all
debug_options ALL,1 33,2
visible_hostname ProxyTest
cache_mgr myemail@.com”

my smb.conf

[global]
workgroup = domain
netbios name = proxy
server string = Luciano
unix charset = LOCALE
log leve = 5
log file = /var/log/samba/LOG.%m
max log size = 50
load printers = yes
domain master = yes
security = domain
wins server = serverIP
password server = serverIP
encrypt passwords = yes
idmap uid = 10000-20000
idmap gid = 10000-20000
winbind enum users = yes
winbind enum groups = yes
socket options = TCP_NODELAY_SO_RCVBUF=8192_SO_SNDBUF_8192
smb passwd file = /usr/local/bin/smbpasswd
local master = no”
 
Old 04-03-2009, 06:27 AM   #2
SonJelfn
Member
 
Registered: Aug 2003
Location: Sendai, Japan
Distribution: Slackware, Slackware64, Debian
Posts: 63

Rep: Reputation: 17
Hello,

wbinfo only tests your authentication method, which I'm guessing was never a problem.

If Squid is asking you to authenticate again after a short time, then you have to change this line to have the credentials last a little longer:

Code:
auth_param basic credentialsttl 1 minute
The documentation page of Squid-cache.org should help you out:

http://www.squid-cache.org/Doc/config/auth_param/

Hope that helps,

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid: squid_ldap_auth "ERR Success" Gitzo645 Linux - Server 13 05-07-2009 10:40 AM
squid_ldap_auth with ADS ksri07091983 Linux - Server 1 12-26-2007 07:20 PM
Squid + Active Directory "squid_ldap_auth " RedCamel Linux - Software 1 12-24-2007 04:01 AM
squid_ldap_auth niranjan_mr Linux - Software 1 07-28-2005 11:16 AM
MNF 8.2 and squid_ldap_auth with openldap v3 outburst Mandriva 0 04-30-2004 06:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration