LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-04-2012, 10:40 AM   #1
Thakowbbery
Member
 
Registered: Mar 2005
Posts: 138

Rep: Reputation: 17
Squid slow upload - Everything else works fine


As the title implies.

The configuration is a CentOS 6.2 running Squid 2.7STABLE9 + inComum helper (http://sourceforge.net/projects/incomum/ - Youtube caching). Squid 2.7 was chosen because inComum is not supported with Squid 3.x.

Squid is using a very basic configuration (no cache hierarchy, no delay_pools, no access control, no transparent proxy) with only black/white listing. Squid is running solo (network firewall is being provided by another machine).

Internet access and content caching are working okay. The main issue is with uploading.

When I try to upload anything (file sharing, mail attachment and so on) it goes extremely slow. Iīve already pinpointed it to Squid being the source, but I canīt find out why.

Hereīs what Iīve tested:

1. Removed browser proxy configuration so internet access goes directly through the firewall: Uploadīs normal
2. Removed browser proxy configuration and set default gateway as the squid machine (SNAT rules adjusted to allow that); squid service is shutdown: Uploadīs normal
3. Set browser proxy configuration; squid is running: Uploadīs slow

Tests were made using the same file and the same website (Gmail mail attachment). I canīt seen to find the cause. Iīve found some people with the same issue but no one had any answer so far.

Any ideas?

Thank you very much.
 
Old 06-06-2012, 03:26 PM   #2
Thakowbbery
Member
 
Registered: Mar 2005
Posts: 138

Original Poster
Rep: Reputation: 17
Well, once again answering my own questions. Although I just canīt explain or understand why, the solution was to put Squid and Firewall into the same box.
 
Old 02-14-2014, 02:16 AM   #3
ganesh24pal@gmail.com
Member
 
Registered: Jun 2010
Location: Mumbai, India
Distribution: CentOS , Fedora, Open Suse
Posts: 193
Blog Entries: 5

Rep: Reputation: 3
Quote:
Originally Posted by Thakowbbery View Post
Well, once again answering my own questions. Although I just canīt explain or understand why, the solution was to put Squid and Firewall into the same box.
r u got soltuion of this, i am also facing same issue.
We had configured Squid 3 on Ubuntu 13 server.

http://www.linuxquestions.org/questi...ow-4175494605/
 
Old 02-14-2014, 10:26 AM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 22,235

Rep: Reputation: 5973Reputation: 5973Reputation: 5973Reputation: 5973Reputation: 5973Reputation: 5973Reputation: 5973Reputation: 5973Reputation: 5973Reputation: 5973Reputation: 5973
Quote:
Originally Posted by ganesh24pal@gmail.com View Post
r u got soltuion of this, i am also facing same issue.
We had configured Squid 3 on Ubuntu 13 server.

http://www.linuxquestions.org/questi...ow-4175494605/
Again, you need to spell out your words, and don't double post questions. You asked this in another thread, and reopened a thread that was closed for two years to do it...please read the LQ Rules. Post reported.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot attach/upload JPEG files through any website. Other file formats are fine. yamel Linux - Newbie 11 07-02-2009 02:18 PM
e0 will Rx, but not Tx...e1 works fine giant Linux - Networking 2 09-15-2004 02:13 PM
Works just fine...I think /home/kyle Linux - Software 0 03-10-2004 06:09 AM
printer works fine in windows but is slow under linux nef Linux - Hardware 4 09-28-2003 03:39 PM
ProFTPd, all works except upload. vexer Linux - Software 0 06-18-2003 12:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration