Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 08-20-2004, 12:08 PM   #1
LQ Newbie
Registered: Oct 2003
Posts: 18

Rep: Reputation: 0
Squid messing up Internal Website

I am using Squid and Dansguardian on one machine to filter pornographic sites. I set up the client browsers to go to the server at 8080. I have an internal webserver called MUSForum with an ip of If I don't have the client browsers configured with the proxy then I can get to http://musforum just fine, but when the proxy is configured in the browser and I try to go to http://musforum then I get this

The requested URL could not be retrieved

While trying to retrieve the URL: http://musforum/

The following error was encountered:

Unable to determine IP address from host name for musforum

The dnsserver returned:

Server Failure: The name server was unable to process this query.

This means that:

The cache was not able to resolve the hostname presented in the URL.
Check if the address is correct.

Your cache administrator is webmaster.

If I go to then I can get to the home page, but if I click on any link it will show the same error page as above. It seems to be something with the proxy server not resolving the name MUSForum. I even went into /etc/hosts and added musforum, but that didn't do anything.
Old 08-20-2004, 12:46 PM   #2
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Take a look at:
DNS entry in the reverse proxy server

You need to configure Intranet DNS and Internet DNS. You can configure split DNS if you want both the DNS in same machine. Instead of Intranet DNS you can have domain entries in /etc/hosts. You have to configure squid with --disable-internal-dns to use /etc/hosts file lookup.
Old 08-20-2004, 01:56 PM   #3
LQ Newbie
Registered: Oct 2003
Posts: 18

Original Poster
Rep: Reputation: 0
That looks like it will be a problem. I am using Suse 9.1 and at first I tried installing squid from source, but suse didn't like that. I used YAST to install squid and now it works. So is there a way to configure squid with the --disable-internal-dns if you don't have the source?
Old 08-20-2004, 03:20 PM   #4
LQ Newbie
Registered: Oct 2003
Posts: 18

Original Poster
Rep: Reputation: 0
Is there no way to add the --disable-internal-dns option in YAST or if you do an rpm -ivh install?? This sucks because the squid source definately doesn't work on Suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
internal website? ryedunn Linux - Newbie 1 12-31-2004 03:54 PM
squid website blocking? belkens Linux - Networking 2 12-11-2004 07:34 AM
Squid is blocking me out of one particular website. danielw Linux - Software 0 07-02-2004 11:30 PM
Permit access to only one website from a station in the internal network rocordial Linux - Security 20 06-06-2004 06:58 PM
Netgear router blocking website when using internal network esteeven Linux - Networking 8 09-30-2003 07:48 AM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:56 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration