LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Squid messing up Internal Website (https://www.linuxquestions.org/questions/linux-networking-3/squid-messing-up-internal-website-220218/)

Osiris123d 08-20-2004 12:08 PM

Squid messing up Internal Website
 
I am using Squid and Dansguardian on one machine to filter pornographic sites. I set up the client browsers to go to the server at 192.168.11.2 8080. I have an internal webserver called MUSForum with an ip of 192.168.1.3. If I don't have the client browsers configured with the proxy then I can get to http://musforum just fine, but when the proxy is configured in the browser and I try to go to http://musforum then I get this

------------------------------------------------------
The requested URL could not be retrieved

While trying to retrieve the URL: http://musforum/

The following error was encountered:

Unable to determine IP address from host name for musforum

The dnsserver returned:

Server Failure: The name server was unable to process this query.

This means that:

The cache was not able to resolve the hostname presented in the URL.
Check if the address is correct.

Your cache administrator is webmaster.
-------------------------------------------------------------------

If I go to http://192.168.1.3 then I can get to the home page, but if I click on any link it will show the same error page as above. It seems to be something with the proxy server not resolving the name MUSForum. I even went into /etc/hosts and added 192.168.1.3 musforum, but that didn't do anything.

david_ross 08-20-2004 12:46 PM

Take a look at:
http://squid.visolve.com/squid/reverseproxy.htm
Quote:

DNS entry in the reverse proxy server

You need to configure Intranet DNS and Internet DNS. You can configure split DNS if you want both the DNS in same machine. Instead of Intranet DNS you can have domain entries in /etc/hosts. You have to configure squid with --disable-internal-dns to use /etc/hosts file lookup.

Osiris123d 08-20-2004 01:56 PM

That looks like it will be a problem. I am using Suse 9.1 and at first I tried installing squid from source, but suse didn't like that. I used YAST to install squid and now it works. So is there a way to configure squid with the --disable-internal-dns if you don't have the source?

Osiris123d 08-20-2004 03:20 PM

Is there no way to add the --disable-internal-dns option in YAST or if you do an rpm -ivh install?? This sucks because the squid source definately doesn't work on Suse


All times are GMT -5. The time now is 06:29 AM.