-   Linux - Networking (
-   -   Squid - Authentication (

TechnoBod 06-11-2003 05:21 PM

Squid - Authentication
Hello all,

I have had a redaht 8 box running squid 2.4 stable 7, SMB_AUTH, and sarg running for the last year.

Unfortunately, earlier today it suffered a serious crash and I had to re-install it with Redhat 9. This comes with a newer version of squid, 2.5 stable-X.

I could not use my old squid.conf since the new version of squid has added options and some options have been discontinued. After a while I now have squid running again.

I have tried to make it work with smb_auth, but it doesn't seem to work on this new setup.....

Can any one help by offering advice.

I need to have all users authenticated against my Windows NT 4 PDC.

Can anyone recomend a solution that will validate the user against the PDC and log their username to access.log ????

unSpawn 06-13-2003 06:03 AM ?

dulantha 06-22-2003 08:22 PM

Post your conf.. I have RH9 and smb_auth working..
If you haven't solved it by now..
Post your auth section and acl section I will take a look see.
I have this working OK..

Also what samba version are you running?


TechnoBod 06-23-2003 08:19 AM

thanks for the offer of help but I've cracked it.

The problem was that smb_auth was looking in the wrong location for the nmblookup programme. after a little play around i managed to track down the problem..

after editing the SAMBAPREFIX option to look to the right directory, it all started working again...

All times are GMT -5. The time now is 12:47 AM.