-   Linux - Networking (
-   -   Some questions about remote desktop (

byvis 08-17-2004 06:58 AM

Some questions about remote desktop

So here the deal. I have Slackware v10.0 setup on my home computer, but unfortunely I'm working... And from 8.00 to 17.00 i have no time to slack :-) My computer at work is with Windows 95 and I have plenty of time to do what I want. So I've came up with an remote desktop idea. Grabbed a lot of info about that and... Well, my machine's ip adress is local. I use an old pc as a router on my network to share DSL. I've installed and started X11vnc on my home machine. Seems that everything is ok, but when i try to connect with Tightvnc from work I get an error telling me that connection to server failed. Here is my x11vnc info:

display: :0
subwin: 0x0
flashcmap: 0
force_idx: 0
scaling: 0 1.00000
visual: null
viewonly: 0
shared: 0
conn_once: 1
connect: null
connectfile null
vnc_conn: 0
authfile: null
allow: null
passfile: null
accept: null
gone: null
inetd: 0
using_shm: 1
flipbytes: 0
blackout: null
xinerama: 0
logfile: null
bg: 0
mod_tweak: 1
isolevel3: 0
xkb: 0
skipkeys: null
addkeysyms: 0
xkbcompat: 0
clearmods: 0
remap: null
nofb: 0
watchbell: 1
watchsel: 1
watchprim: 1
loc_curs: 1
mouse: 0
root_curs: 0
xwarpptr: 0
cursorpos: 1
buttonmap: null
dragging: 1
old_ptr: 0
inputskip: 10
norepeat: 0
debug_ptr: 0
debug_key: 0
defer: 30
waitms: 30
take_naps: 0
sigpipe: 1
threads: 0
fs_frac: 0.75
onetile: 0
gaps_fill: 4
grow_fill: 3
tile_fuzz: 2
version: 0.6.2 lastmod: 2004-07-31
Using X display :0
Read initial data from X display into framebuffer.

17/08/2004 12:45:16 Using X display with 32bpp depth=24 true color
17/08/2004 12:45:16 Autoprobing TCP port
17/08/2004 12:45:16 Autoprobing selected port 5900
17/08/2004 12:45:16 screen setup finished.
17/08/2004 12:45:16 The VNC desktop is Box:0

As you got it:
Host is Box
Display is 0
Port is 5900
Protocl TCP

In TightVnc I tried to use the commands:
My ISP provided IP adresss(dynamic by the way);

Neither of these worked. As far as I understand it's connecting problems and x11vnc is set properly. From one of the post I found this:

"You need your router to forward port 22 to your linux box and then point Putty at your WAN IP address (the one your router gets from your ISP). You probably should also check your linux firewall to make sure it allows traffic on port 22."

I think the problem is forwarding, but I'm using a BBIagent. I think I got the idea about forwarding but if it's possible can someone confirm am I doing it right(cause I not tried it yet, I@work :-) ).
These setting are set at BBIagent:

Router port - 22, right? The port which is typed in TightVnc or Putty
Protocol - TCP
Service Host on Lan - My Internal IP adress. Were to forward.
Service Port - 5900, right? What port to use for my home pc or in other words, x11vnc created port. Or maybe I should leave it 22? Here I'm confused.

Well that's the deal. I'm asking this cause I can't leave my work and everything I have to do in the evening and try it only in the morning.

P.S. Is everything is going to be ok, I'll surelly write a full guide how to create that damn remote desktop with a internal pc. Or maybe it;s writen already? As far as I googled, there is no :(

david_ross 08-17-2004 01:35 PM

Welcome to LQ.

Port 22 would only be needed if you are tunneling over ssh.

Can you connect to your vnc server from another machine on your LAN?

byvis 08-18-2004 12:19 AM

Thanks for the welcome :-)

No I haven't tried, but i'll surely do that as soon as possible. But for noweveything works over Putty. But I can't startX :( ssh tells me that a display manager is already running. Yes, on my locale machine KDE is running, is this the problem?

david_ross 08-18-2004 03:47 PM

Yes, you can only start one window manger at a time, just run the individual applications that you want to run rather than another window manager.

arno 08-18-2004 04:00 PM

Someone indeed has written an howto

byvis 08-19-2004 12:25 AM

Thank God I've figured it out. AS I suspected the problem was port forwarding. Now eveything is ok :-)

All times are GMT -5. The time now is 01:43 AM.