-   Linux - Networking (
-   -   (SOLVED) Fedora 14 wireless random successful connection, DHCPDISCOVER fails (

zQUEz 12-18-2010 09:51 AM

(SOLVED) Fedora 14 wireless random successful connection, DHCPDISCOVER fails
My Fedora 14 installation using NetworkManager to control my Linksys USB wireless adapter, very randomly succeeds in getting a connection to my Linksys router. The symptoms I saw were:
1) I always saw my router SSID listed without issues. 100% signal strength (it is in the same room).
2) /var/log/messages always showed a successful connection, but during the DHCP phase it would always just timeout and report no IP address information and drop the connection.
3) Running NetworkManager from commandline basically showed the same thing in its verbose messages - i.e. DHCP issue.
4) The router logs showed a successful connection from my desktop and that an IP address and configuration was issued. MAC address reported was correct also.
5) I wasn't getting errors from seLinux (I set to permissive anyway) or iptables with logging enabled (i turned off also for troubleshooting).
6) Very rarely (perhaps 2% of the time) it would connect without issues. But when I disconnected and re-connected it would have the same issues.
7) I didn't see any issues with other Windows or appliances (e.g. Roku) connecting.

The issue appears to have been resolved by going into the router configuration, and changing the WPA2 encryption settings from TKIP+AES to just AES.

Just thought I would post this in case others come across this.

repo 01-16-2011 11:40 AM

Thanks for sharing

Kind regards

All times are GMT -5. The time now is 12:55 PM.