LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 09-16-2015, 05:31 AM   #1
Techbart
LQ Newbie
 
Registered: Jan 2010
Posts: 2

Rep: Reputation: 0
SNMP not responding on Gentoo


I've installed SNMP on a pretty clean copy of Gentoo, with minimal services running alongside, such as apache, samba, teamspeak and a Minecraft server. Otherwise it's as close to core as I can manage, no X11, no SELinux or IPtables. However, after installing SNMP and attempting to use its example conf file, I can't get a response from snmpwalk. I've tried altering the example file, following various versions of an snmpd.conf file from other Gentoo users, even resorting to using just "rwcommunity public" as the only line in a snmpd.conf file. Nothing works.

I've established with netstat -tulpen that snmpd is active and using port 161 UDP. I've tried performing exactly the same steps on another Gentoo machine, and snmpd was able to respond immediately to a snmpwalk query, so I'm only left with the conclusion that something in this system is either misconfigured, or interfering with snmp. Been bashing my head on this for the best part of a day, so any help would be muchly appreciated. Cheers!
 
Old 10-02-2015, 03:53 PM   #2
Pearlseattle
Member
 
Registered: Aug 2007
Location: Zurich, Switzerland
Distribution: Gentoo
Posts: 999

Rep: Reputation: 142Reputation: 142
Hi
Do you HAVE to use SNMP?
Asking because I hated it in the past and because you'll end up having problems (e.g. the limit of some 32bit counters like bytes read from HDD or network, which will reset to 0 once you reach their maximum value).
IF you can choose options, then I strongly recommend you to use "collectd" to gather your stats across all your servers, "influxdb" or "graphite/whisper" to store them and "grafana" to plot them.

Back to your original question, it's probably an issue with the server config and/or query (brilliant, isn't it? ).
You'll therefore have to stick to the simpliest config and query, post it here and see what the community says.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SNMP Configuration problem - able to snmp outbound, unable to snmp inbound. sumncguy Linux - Desktop 2 04-28-2015 09:26 AM
[SOLVED] SNMP querys to Squid not responding mrpurple Linux - Server 5 10-22-2012 05:42 PM
Gentoo - addition of "ucd-snmp/diskio" module to Net-SNMP ursusca Linux - Server 2 08-03-2012 02:59 AM
Net-SNMP writing a Subagent - snmp.conf Unknown token: master AustinMarton Programming 0 12-16-2008 07:34 PM
snmp (ucd-snmp, net-snmp) markus1982 Linux - Software 1 11-21-2002 10:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration