LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Snmp / Cfgmaker problem (https://www.linuxquestions.org/questions/linux-networking-3/snmp-cfgmaker-problem-4175582360/)

thomazp 06-15-2016 02:54 PM

Snmp / Cfgmaker problem
 
# cfgmaker netcomro@172.27.252.3
SNMP Error:
no response received
SNMPv1_Session (remote host: "172.27.252.3" [172.27.252.3].161)
community: "netcomro"
request ID: 2076299575
PDU bufsize: 8000 bytes
timeout: 2s
retries: 5
backoff: 1)
at /usr/bin/../lib64/mrtg2/SNMP_util.pm line 629
SNMPWALK Problem for 1.3.6.1.2.1.1 on netcomro@172.27.252.3::::::v4only
at /usr/bin/cfgmaker line 950
WARNING: Skipping netcomro@172.27.252.3: as no info could be retrieved

I saw a snmp service(snmptrapd) down. I put it up and the result was the same. ;-(

Habitual 06-16-2016 08:06 AM

Code:

telnet 172.27.252.3 161
Traps it seems use port 162

http://catb.org/~esr/faqs/smart-questions.html

thomazp 06-16-2016 08:37 AM

Here we Can't use telnet, I tried ssh onstead and seemed working.

thomazp 06-16-2016 09:17 AM

I ask to see if The router is accepting both 161 and 162 , also along the route.
They will do it afternoon today and I post the results here.
Tks

Habitual 06-16-2016 10:20 AM

nc ?

thomazp 06-16-2016 10:25 AM

Didn't understand what it means.

Habitual 06-16-2016 10:49 AM

netcat # since there's no telnet client.
https://www.digitalocean.com/communi...tions-on-a-vps

Code:

nc -z 172.27.252.3 161

Habitual 06-16-2016 10:54 AM

How was this cfgmaker installed exactly?
What OS and build is this on?
What version of snmpd?

Can you snmpwalk manually to 172.27.252.3 for the 1.3.6.1.2.1.1 OID?
version 2 I suspect.

thomazp 06-16-2016 11:23 AM

The log isn't enabled.
Comes an error: No security name specified.

Habitual 06-16-2016 11:31 AM

Show us the command used please.

thomazp 06-16-2016 11:37 AM

Two tries:
snmpwalk 172.27.252.3 1.3.6.1.2.1.1
No log handling enabled - turning on stderr logging
snmpwalk: No securityName specified
And
snmpwalk 172.27.252.3
Same result

I had used the second to test SNMP connection in the past.

Habitual 06-16-2016 12:17 PM

Is the snmpd.conf on 172.27.252.3 configured for access ?\

Maybe it's time I ask you what you are trying to achieve.
What is the goal?

You're using snmpwalk incorrectly:
Example:
Code:

snmpwalk -v 2c -c mysecretsnmp 172.27.252.3 1.3.6.1.2.1.1
So I refer you to http://www.net-snmp.org/

So, on 172.27.252.3 you'll need to configure the "community" (you used "netcomro" earlier?)
and what they'll have access to.

Lots of examples on the web:
https://duckduckgo.com/?q=snmp+walk+...e+linux&ia=web

thomazp 06-16-2016 12:20 PM

I asked them to verify for me, they will answer this afternoon.
Is there any way to test and tell them the problem is there ?

Habitual 06-16-2016 12:26 PM

Quote:

Originally Posted by thomazp (Post 5561977)
I asked them to verify for me, they will answer this afternoon.
Is there any way to test and tell them the problem is there ?

Test what?
I have only your improper use of the snmpwalk command.
Edited: See above^

Also:
You didn't answer:
http://www.linuxquestions.org/questi...0/#post5561920

So, I'm waiting on that before I invest too much more time.
Make certain ports 161 and 162 are open on the snmp host being queried and the client machine doing the query.

thomazp 06-16-2016 12:30 PM

I don't have NC command.
The Community is correct.


All times are GMT -5. The time now is 09:38 AM.