LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-02-2004, 11:36 PM   #1
cpugeniusmv
LQ Newbie
 
Registered: Feb 2004
Posts: 9

Rep: Reputation: 0
smbfs in fstab


from /etc/fstab:
Quote:
//cpugeniusmv/MyDocs /home/mike/MyDocs smbfs guest,uid=1000,gid=100,fmask=644,dmask=755 0 0
it works when i type mount /home/mike/MyDocs...but not on boot.

i'm in slackware-current, i've checked /etc/rc.d/rc.inet2 and it is finding the smbfs in fstab, and i guess it's trying to mount it...(i put in a touch after the mount, but inside the 'if'...and it was there.)

i tried putting the exact command

Quote:
/sbin/mount //cpugeniusmv/MyDocs /home/mike/MyDocs -t smbfs -o guest,uid=1000,gid=100,fmask=644,dmask=755
in with mount -a -t smbfs...no good.

i also tried putting the command in rc.local, but that didn't work.

suggestions?
 
Old 04-03-2004, 02:44 AM   #2
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
You've done all that, but you haven't tried using the "auto" option in your original mount command?

That's usually what makes a mount automatic at boot time, but I've never tried it with a Samba mount in fstab (I usually use LinNeighborhood to mount my memorized shares, and that runs at login-- which is more or less the same thing as far as the user is concerned). But try it and see if you get any errors indicating that the drives can't be mounted at boot for whatever reason. I don't think you should, though; if you can put all those other options in your fstab command and have them work, "auto" should too.
 
Old 04-03-2004, 02:29 PM   #3
cpugeniusmv
LQ Newbie
 
Registered: Feb 2004
Posts: 9

Original Poster
Rep: Reputation: 0
i forgot to mention that , i did try auto...and that gave me an error. something about an "invalid argument"

i guess that's not a valid option for smbfs.

i can't really have it wait until login to mount the drive, because typically no one logs in to this machine. it's just connected to power and ethernet, it's my file/print/gameserver.

if anyone else has any ideas, i'd be greatful...but i guess i can just login via SSH and mount it if i ever have to reboot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why fstab doesn't mount smbfs rjkfsm Linux - Newbie 3 12-16-2011 01:23 PM
Delay fstab mount of smbfs during boot Iron City Linux - General 7 01-21-2009 03:58 PM
mounting an smbfs share using mount vs /etc/fstab sichen Linux - Networking 4 08-13-2004 07:40 PM
RH9 mounting SMBFS from fstab - Jefficus Linux - Networking 24 11-24-2003 05:14 PM
SMBFS & FStab SWAT Linux - Software 6 09-02-2003 09:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration