LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   smbfs in fstab (https://www.linuxquestions.org/questions/linux-networking-3/smbfs-in-fstab-165574/)

cpugeniusmv 04-02-2004 11:36 PM

smbfs in fstab
 
from /etc/fstab:
Quote:

//cpugeniusmv/MyDocs /home/mike/MyDocs smbfs guest,uid=1000,gid=100,fmask=644,dmask=755 0 0
it works when i type mount /home/mike/MyDocs...but not on boot.

i'm in slackware-current, i've checked /etc/rc.d/rc.inet2 and it is finding the smbfs in fstab, and i guess it's trying to mount it...(i put in a touch after the mount, but inside the 'if'...and it was there.)

i tried putting the exact command

Quote:

/sbin/mount //cpugeniusmv/MyDocs /home/mike/MyDocs -t smbfs -o guest,uid=1000,gid=100,fmask=644,dmask=755
in with mount -a -t smbfs...no good.

i also tried putting the command in rc.local, but that didn't work.

suggestions?

motub 04-03-2004 02:44 AM

You've done all that, but you haven't tried using the "auto" option in your original mount command?

That's usually what makes a mount automatic at boot time, but I've never tried it with a Samba mount in fstab (I usually use LinNeighborhood to mount my memorized shares, and that runs at login-- which is more or less the same thing as far as the user is concerned). But try it and see if you get any errors indicating that the drives can't be mounted at boot for whatever reason. I don't think you should, though; if you can put all those other options in your fstab command and have them work, "auto" should too.

cpugeniusmv 04-03-2004 02:29 PM

i forgot to mention that :), i did try auto...and that gave me an error. something about an "invalid argument"

i guess that's not a valid option for smbfs.

i can't really have it wait until login to mount the drive, because typically no one logs in to this machine. it's just connected to power and ethernet, it's my file/print/gameserver.

if anyone else has any ideas, i'd be greatful...but i guess i can just login via SSH and mount it if i ever have to reboot.


All times are GMT -5. The time now is 02:28 PM.