LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-28-2015, 10:07 PM   #1
dgermann
Member
 
Registered: Aug 2004
Distribution: Ubuntu 16.04 lts desk; Ubuntu 14.04 server
Posts: 366

Rep: Reputation: 31
Question smb openvpn "suitable address" error


Friends--

Have three computers mounting samba shares, and failing mount.cifs on two others.

Production environment, trying to set up a new server, named torus. There is an existing server named mariah, and clients can mount its shares.

torus locally is 192.168.0.203; its tun is 10.8.20.1. Runs Ubuntu 14.04 lts.
mariah locally is 192.168.0.202; its tun is 10.8.1.1.
fire is local client at 192.168.0.6; its tun on torus is 10.8.20.5. fire can mount.cifs the torus shares from the tun 10.8.20.1.
wind is remote client with tun on torus at 10.8.20.13
air is the client with problems. Locally it is 192.168.0.212, and its tun address for torus is 10.8.20.21. (Have also tried installing to another client, kudu, and get the same error, although the openvpn connects.)
All clients but kudu run Ubuntu 12.04 lts, and kudu runs 14.04 lts.
There is another client, svs2, which runs winxp, and it has no problems connecting nor mounting the shares.

All clients, with the exception of wind are behind the router serving 192.168.0.x; they all address the tun via a dynamic dns service.

torus and all clients on tun 10.8.20.x can ping air at its tun address, and air can ping all them on their 10.8.20.x addresses.

So here is the sequence on air: the openvpn connections succeed. Then I do a mount -av, and get this response:

Code:
doug@air:~$ sudo mount -av
mount: proc already mounted on /proc
mount.cifs kernel mount options: ip=10.8.20.1,unc=\\torus\vol1,noexec,nosuid,nodev,nobrl,credentials=/root/.toruscredentials,uid=1000,gid=1003,ver=1,user=doug,pass=********
Unable to find suitable address.
doug@air:~$
Have also gotten this error:

Code:
Credential formatted incorrectly: (null)
Searching the Web the last several nights (after 5-6 hours testing and troubleshooting), it appears to me that these error messages point to a whole host of problems, none of which seem to be what I am experiencing!

The toruscredentials file is:
Code:
username=doug
password=**********
I copied that from the file that reliably connects to the samba server on mariah, and the only difference is that the password is different.

If I try to mount these exact same shares, with the same credentials file over the local network at 192.168.0.x, it mounts OK.

My guesses:

Since we can ping back and forth across the openvpn 10.8.20.x, the connection there seems good.

Since we can connect to the samba shares using the lan 192.168.0.x, then it seems something is incompatible in the samba setup.

There is an iptables firewall on torus; the problem persists whether that is active or non existent: so that seem not to be an issue. There is no firewall on any of the clients at the time these tests are run.

Have checked and apt-get says openvpn on air is already newest version; same for cifs-utils; samba is **not** installed (which seems right).

I have tried:

--Disconnecting air from the mariah tun interface and umount-ing all mounts, then connect only to torus: same error messages.

--Disconnecting wind from the torus tun and try to connect with air: same error messages.

--Setting up the openvpn connection on kudu with same error messages. It also can connect via the lan, but not via tun.

--Checked ifconfig for errors and none are reported

--None of the clients has a /var/log/messages file.

--Checked the permissions in the /etc/openvpn directory, and checked and rechecked the torus.conf file there against the mariah.conf file and see no obvious problems.

--edited smb.conf to provide access to the 10.8.20.x tun. Here is the smb.conf on torus:


Code:
[global]
        workgroup = EVERYONE
        server string = h server (Samba, Ubuntu)
        map to guest = Bad User
        obey pam restrictions = Yes
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:
* %n\n *password\supdated\ssuccessfully* .
        unix password sync = Yes
        lanman auth = Yes
        client lanman auth = Yes
        client plaintext auth = Yes
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        printcap name = cups
        disable spoolss = Yes
        show add printer wizard = No
        hosts allow = 192.168.0.0/24 10.8.0.0/24 127.0.0.1
        #interfaces = 192.168.0.0/24 10.8.0.0/24 10.8.20.0/24 10.8.1.0/24 
########ddg20151026
        interfaces = eth* tun* lo
        bind interfaces only = yes
#######
        dns proxy = No
        usershare allow guests = Yes
        panic action = /usr/share/samba/panic-action %d
        create mask = 0775

[printers]
        comment = All Printers
        path = /var/spool/samba
        create mask = 0700
        printable = Yes
        browseable = No
        browsable = No

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/printers
[homes]
        comment = Home Directories
        valid users = %S
        read only = No
        browseable = No
        browsable = No

[vol1]
        path = /vol1
        valid users = doug, [blanked]
        force user = doug
        force group = apps
        read only = No

[vol2]
        path = /vol2
        valid users = doug, [blanked]
        force user = doug
        force group = data
        read only = No
[label]
        path = /vol1/apps/label
        valid users = doug, [blanked]
        force user = doug
        force group = data
        read only = No

[doug2]
        path = /doug2
        valid users = doug
        force user = doug
        force group = doug
        read only = No
        browseable = No
        browsable = No

[etc]
        path = /etc
        valid users = doug
        force user = doug
        force group = doug
        read only = No
        browseable = No
        browsable = No
[home]
        path = /home
        valid users = doug
        force user = doug
        force group = doug
        read only = No
        browseable = No
        browsable = No
Not sure where to go from here. How would you trouble shoot this? I must be missing something obvious....

Thanks from a tired and exasperated...

Last edited by dgermann; 10-28-2015 at 10:10 PM.
 
  


Reply

Tags
mount.cifs, openvpn, samba, suitable


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Cannot mount remote filesystem. Error "Unable to find suitable address" alankenyon55 Linux - Newbie 12 12-02-2014 11:47 PM
[SOLVED] "net rpc" "failed to connect to ipc$ share on" or "unable to find a suitable server" larieu Linux - General 0 11-09-2014 12:45 AM
openvpn ipaddress problem: "MULTI: bad source address from client" arobinson74 Linux - Networking 6 10-02-2008 06:26 PM
difference between "service smb restart" and "/etc/rc.d/init.d/smb" powah Linux - Software 1 01-17-2007 05:17 PM
"X-MS" cant open because "x-Multimedia System" cant access files at "smb&qu ponchy5 Linux - Networking 0 03-29-2004 11:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration