-   Linux - Networking (
-   -   smb mount folders disappear on mount & konqueror smb fails: network unreachable (

tisource 02-22-2005 02:23 PM

smb mount folders disappear on mount & konqueror smb fails: network unreachable
First, I know there are a ton of samba connection error topics in this forum. This one, however, is nothing like I've ever seen.

Our server had some disk problems (apache's server cache got out of hand), so I took it down for a reboot. I did a disc check on boot, and cleaned up the root (/) filesystem. It appears to be in tact, and everything but smb-client works great.

When it came back up, I am no longer able to mount samba shares properly. I can mount them (no errors), but when I do, the mount folder disappears from view until I unmount them.

Normally, I mount the shares via fstab on boot, and everything has been fine for months, until now. I tried mounting them manually, and got the same results. mount returns no errors, and shows it as mounted.

In MC, it shows up as '?mountdir' with the date of 1969. I fired up X and tried to connect to the share via Konqueror (smb://), and could connect just fine. That tells me the samba client is ok.

I do have other network services running on this linux box, and they work fine (DHCP, DNS, HTTP, etc). In fact, the box is also a samba server. I can connect to the samba server from my workstation just fine. I have also verified that mounts only fail on shares from our windows 2003 domain controller.

No, I don't have a firewall of any kind running at the moment. I have verified all the ports are open.

Any ideas? I reinstalled the samba-client package, to no avail. This one has really got me stumped. I have never seen anything like it.

gti666 10-17-2007 01:30 AM

I am experiencing the same thing mounting a Samba share residing on an OSX Server (10.4) machine.

The mount point folder is there (ls shows it) but once I issue the mount command, the mount point disappears and ls reports 'Permission denied' even though I am root... :-/

All times are GMT -5. The time now is 12:47 AM.