LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-10-2017, 11:51 AM   #1
EvanShaw
LQ Newbie
 
Registered: Feb 2017
Location: Las Vegas, NV
Distribution: Ubuntu GNOME
Posts: 5

Rep: Reputation: 0
Slow WiFi on Intel Centrino Ultimate-N 6300


This is my first post here. I've been using linux in my professional life for years but I am by no means an expert.

The machine in question is a ThinkPad W530 with an Intel Corporation Centrino Ultimate-N 6300 [8086:4238] (rev 3e)

When booting to Windows 10, the wireless performance is excellent. However, when booting to Ubuntu the speeds seem to be "capped" at 2MB/sec. SpeedTest.net confirms I am getting about half the download speed under linux.

Link to wireless info script output: http://pastebin.com/NcfznVBg

There are many old posts related to this card. Some of the solutions seem to be outdated, others simply don't seem to work.

Any wizards here with ideas on how to fix this is appreciated. The machine is usable, just not practical with the "speed cap".
 
Old 02-10-2017, 03:17 PM   #2
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,367
Blog Entries: 10

Rep: Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854
EvanShaw,

Welcome to LQ.

Thanks for the wifi info script with plenty of details. This makes a pleasant change!

There are two main things you can do to speed up your Intel Centrino Ultimate N 6300. The second mod will probably have more effect.

First install gedit and gksu.

Open a Terminal and type:

Code:
sudo apt-get update
Press Enter, give your password (nothing displayed for security reasons) and press Enter again.

Code:
sudo apt-get install gksu gedit
Press Enter.

Your Power Management is on, so proceed as follows to disable powersave.

Copy and paste this line into a Terminal:

Code:
gksudo gedit /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
Press Enter, ignore any warnings and in the text file:

Change the existing 3 to 2 so that the file reads:

Code:
wifi.powersave = 2
File > Save > File > Quit and reboot laptop.


Next copy and paste this line into Terminal:

Code:
echo "options iwlwifi 11n_disable=8" | sudo tee /etc/modprobe.d/iwlwifi11n.conf
Press Enter, give your password and press Enter again.

Reboot.

Check the wifi speed.

If you have problems, then remove the modification:

Code:
sudo rm -v /etc/modprobe.d/iwlwifi11n.conf
Then reboot.

Good luck.
 
Old 02-10-2017, 04:04 PM   #3
EvanShaw
LQ Newbie
 
Registered: Feb 2017
Location: Las Vegas, NV
Distribution: Ubuntu GNOME
Posts: 5

Original Poster
Rep: Reputation: 0
You, sir, have solved my problem that has been causing me to pull my hair out for many months. Thank you so very much. If you don't mind, I'd like to know what exactly I just did.

I understand that the card was in powersave mode, so we disabled that. Then we added the line "options iwlwifi 11n_disable=8" to the config file for the NIC. Does this mean we disabled the Wireless N support? Is this a "hack"?

Thank you again.
 
Old 02-10-2017, 04:52 PM   #4
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,367
Blog Entries: 10

Rep: Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854
EvanShaw,

Glad you fixed your wifi problem.

Quote:
Does this mean we disabled the Wireless N support? Is this a "hack?"
1. Wireless N support is not disabled.

2. You can call it a hack if you wish.

The purpose of the modification is to re-enable TX AMPDU aggregation which always used to be ON by default in the iwlwifi driver.

In recent times the default setting of TX AMPDU is OFF, so all we are doing is putting it back to its original default setting (ON) of yesteryear.

Last edited by beachboy2; 02-10-2017 at 05:02 PM.
 
Old 02-10-2017, 05:26 PM   #5
EvanShaw
LQ Newbie
 
Registered: Feb 2017
Location: Las Vegas, NV
Distribution: Ubuntu GNOME
Posts: 5

Original Poster
Rep: Reputation: 0
Well that went over my head. Thanks again, I am extremely grateful!
 
Old 05-21-2017, 11:23 AM   #6
Mushroomheadbangers
LQ Newbie
 
Registered: Jun 2010
Location: Texas
Distribution: Linux Mint Cinnamon, FreeBSD KDE
Posts: 13

Rep: Reputation: 1
Thumbs up Worked!

This also solved my issue with old System76 laptop on Linux Mint 18.1

If you're unsure whether or not you're using Centrino Ultimate-N 6300 for wireless, here is how I figured it out:

Quote:
lspci -v | grep -iE -5 'wifi'
Quote:
04:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 3e)
Subsystem: Intel Corporation Centrino Ultimate-N 6300 3x3 AGN
Flags: bus master, fast devsel, latency 0, IRQ 36
Memory at f6200000 (64-bit, non-prefetchable) [size=8K]
Capabilities: <access denied>
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi
Thank you!
 
Old 05-30-2017, 05:35 AM   #7
namecaps
LQ Newbie
 
Registered: May 2017
Posts: 1

Rep: Reputation: Disabled
Excellent fix, thanks beachboy2. I just installed Lubuntu on an HP Elitebook 8440p and my wifi wasn't working at all. I googled around for a solution, came across this thread and took a major leap of faith by following the same instructions exactly... and now I have wifi. Awesome!
 
Old 05-30-2017, 08:40 AM   #8
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,367
Blog Entries: 10

Rep: Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854
Smile

namecaps,

First of all, welcome to LQ.

I am glad to have been of assistance.

Just remember to leave a large tip!
 
Old 06-05-2017, 12:57 PM   #9
Knonada
LQ Newbie
 
Registered: Jun 2017
Posts: 2

Rep: Reputation: Disabled
Smile First post.

Thank you so much for this thread! I have been searching for a solution to this problem for months.

I am also not new to Linux, but I am still learning much about it.

I attempted this same procedure, unfortunately it did not increase the speed.

I was wondering if you had any advice. Thank you again.

Code:
lspci -v | grep -iE -5 'wifi'
01:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 35)
	Subsystem: Intel Corporation Centrino Ultimate-N 6300 3x3 AGN
	Flags: bus master, fast devsel, latency 0, IRQ 34
	Memory at d1600000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: <access denied>
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi

02:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04) (prog-if 30 [XHCI])
	Subsystem: Dell uPD720200 USB 3.0 Host Controller
	Flags: fast devsel, IRQ 18
	Memory at d1500000 (64-bit, non-prefetchable) [size=8K]
 
Old 06-06-2017, 01:49 PM   #10
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,367
Blog Entries: 10

Rep: Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854
Knonada,

At the end of the recommended procedure, did you reboot?

Post #2 on this thread has also been useful to some Intel 6300 users:

https://ubuntuforums.org/showthread.php?t=1656061

Code:
gksu gedit /etc/modprobe.d/intel-5300-iwlagn-disable11n.conf
and then modify existing line to read:

Code:
options iwlagn 11n_disable=0
Good luck.
 
1 members found this post helpful.
Old 07-07-2017, 08:29 AM   #11
Knonada
LQ Newbie
 
Registered: Jun 2017
Posts: 2

Rep: Reputation: Disabled
@beachboy2

Thank you for your help.

I think it is running a bit better, and more consistently now.

Have a great day.
 
Old 09-10-2017, 01:15 PM   #12
Artur_
LQ Newbie
 
Registered: Sep 2017
Posts: 1

Rep: Reputation: Disabled
The Linux community is really great... The "11n_disable=8" solution increased my WiFi speed from 30Mb to 95Mb/s. Thank you, @beachboy2.
 
Old 09-11-2017, 02:26 AM   #13
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,367
Blog Entries: 10

Rep: Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854
Artur_,

Welcome to LQ.

I am glad to have been of help to you.
 
Old 10-18-2017, 12:54 PM   #14
jlinguistica
LQ Newbie
 
Registered: Oct 2017
Posts: 1

Rep: Reputation: Disabled
Hello,

I am a new user of Deepin, with almost no experience with Linux. I noticed my connection was poor and found this thread. Unfotunately, it did not helped me yet.

after I enter
Code:
gksudo gedit /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
and type my password, an empty .txt-like file opens. At first, i was pasting

Code:
wifi.powersave = 2
and after rebooting there was no connection and then I installed Deepin again. I tried this 4 times.
 
Old 10-19-2017, 02:35 AM   #15
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,367
Blog Entries: 10

Rep: Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854Reputation: 854
jlinguistica,

Welcome to LQ.

I have no knowledge of Deepin, but it appears from this review that its hardware support can be problematical:
https://www.dedoimedo.com/computers/deepin-15-4.html

My suggestion would be to try another distro such as Linux Mint MATE and see whether that helps matters.

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Pathethic connection speeds compared to WIndows 7 (Intel Centrino Ultimate-N6300 AGN) mxl2 Linux - Wireless Networking 4 02-10-2017 09:12 PM
[SOLVED] CentOS 7, Wifi is not working (Intel Centrino Wireless-N 135). boycottsystemd CentOS 8 08-14-2016 12:39 AM
Dell Inspiron 5520 + WIFI intel centrino n2230 rass al gul Linux - Laptop and Netbook 1 09-04-2012 09:35 AM
Very slow wifi with Centrino N-130 in LUbuntu _-Robin-_ Linux - Wireless Networking 2 02-21-2012 07:28 AM
Intel Centrino Ultimate-N 6300 will not start louisb Linux - Wireless Networking 1 05-30-2010 12:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration