LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-26-2006, 05:10 PM   #1
Sammael
Member
 
Registered: Jun 2006
Location: Slovakia, currently working in Liverpool UK
Distribution: Gentoo 2006.0
Posts: 97

Rep: Reputation: 15
Question slow download/upload on ethernet


hi,

i am running suse 10.1 and connecting via samba server to my friends windows box... what i've noticed is, that i can't download/upload more than 4500-5000 kb/s. under windows i was able to download 10 mb/s. we both have 100mbps network cards. somebody told me that i have to turn off duplex mode, or smthng like that, because that is using only half of my bandwidth to keep other half available for another network communication. is it true? if yes, how can i disable this duplex thingy?

thx
 
Old 06-27-2006, 02:37 PM   #2
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,043
Blog Entries: 14

Rep: Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212
Not likely turning off duplex is the issue. More likely is you're set to "autonegotiate" and should turn that off.

For the Linux side depending on the NIC you can use mii-tool or ethtool to look at current settings and change them.

Some notes I wrote myself a while back:
ethtool command will set NIC parameters:
ethtool -s eth0 autoneg off speed 100 duplex full

NOTE: To force the options at all boots add the following to ifcfg-eth0:
ETHTOOL_OPTS="autoneg off speed 100 duplex full"

mii-tool command will set NIC parameters - older tool than ethtool
mii-tool -F 100baseTx-FD eth1
mii-tool -v eth1 # Shows info about the interface

You can type "man ethtool" or "man mii-tool" to get more info about these commands.
 
Old 06-27-2006, 06:30 PM   #3
Sammael
Member
 
Registered: Jun 2006
Location: Slovakia, currently working in Liverpool UK
Distribution: Gentoo 2006.0
Posts: 97

Original Poster
Rep: Reputation: 15
thank you very much - works as a charm - that's exactly what i was looking for... you see, the biggest problem for me is, that i know it can be done, but i just do not know the command for it. if i would've known that it can be done with ethtool, i would RTFM and would be all set... well, i know it now

thank you again,
have a nice day
 
Old 06-28-2006, 08:39 AM   #4
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,043
Blog Entries: 14

Rep: Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212
No problem. My comment about man pages was just to let you know where to get more information. I seldom respond with RTFM but do usually add a comment about man pages as some people aren't aware they exist.

FYI for anyone else reading the thread - the note ifcfg-eth0 applies to RedHat (and Fedora) but may or may not be valid for other distros.
 
Old 07-13-2006, 09:08 PM   #5
lurko
Member
 
Registered: Jun 2006
Location: Ontario, Canada
Distribution: Debian
Posts: 448

Rep: Reputation: 35
I am basically having the same problem here. I can't seem to break 4MB/s transferring from XP to linux through samba.

My nic is already set at full duplex and 100MB/s so I just ran
Code:
ethtool -s eth0 autoneg off
Now the transfer starts at anywhere between 50 and 110 MB/s, only to slow right back down to 4MB/s after about 5 seconds. before I found this thread I tried adding the stuff in this post to my smb.conf but it didn't help. It's like samba is taunting me now, showing me what it's capable of, before not doing it.

here's my smb.conf's global section:
Code:
[global]
workgroup = HOME
encrypt passwords = yes
wins support = yes from this line on are additions trying to pick up the pace
default service = data

socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
read raw = yes
write raw = yes
oplocks = yes
max xmit = 65535
dead time = 15
getwd cache = yes
anyway turning off autonegotiation is the first thing I've tried that appeared to make any difference at all

Last edited by lurko; 07-13-2006 at 09:10 PM.
 
Old 07-14-2006, 03:56 PM   #6
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,043
Blog Entries: 14

Rep: Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212Reputation: 1212
Remember the setting needs to be the same on both sides of the connection. If you are direct connected to the XP box you probably need to figure out how to check its NIC as well. If going through a router you need to check the router.

For most things setting 100 Full is the way to go as autnegotiate bites.

Also make sure you do the ethtool option to check the settings on your NIC to make sure they are now what you think they are. Turning autonegotiate off may mean it is at 100 half or 10 full or even 10 half.

Example - to see eth0 setttings:

ethtool eth0
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: Not reported
Advertised auto-negotiation: No
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: off
Supports Wake-on: umbg
Wake-on: d
Current message level: 0x00000007 (7)
Link detected: yes

It is the "Speed:" and "Duplex" entries you're interested in seeing. As can be seen here they have 100Mb/s and Full respectively. Note "Auto-negotiation:" is Off but as stated above this doesn't automatically set the other 2 parameters to what you want.
 
Old 07-14-2006, 05:29 PM   #7
lurko
Member
 
Registered: Jun 2006
Location: Ontario, Canada
Distribution: Debian
Posts: 448

Rep: Reputation: 35
everytime I've turned off autoneg with ethtool, I've checked it afterwards, eth0 has always been at 100/full.

I checked my router's(di-604) settings, it is set to 100/full

Turns out my xp box was set to "full autonegotiation", it is now set to "force 100 full duplex"


There is no change whatsoever though. For the first few seconds the transfer taunts me by going as fast as it presumably can(50-100MB/s), then it immediately drops down to 4MB/s.


btw, how do I get autoneg off by default when I boot up in slack 10.2? I do not have the ifcfg-eth0 file mentioned above.

Last edited by lurko; 07-14-2006 at 05:32 PM.
 
Old 07-15-2006, 06:42 PM   #8
lurko
Member
 
Registered: Jun 2006
Location: Ontario, Canada
Distribution: Debian
Posts: 448

Rep: Reputation: 35
thought I'd mention for anyone who's searching on this stuff in future - I've found that if I bypass my smbfs mounts under /mnt and just put smb://192.168.0.166/location.etc in Konqueror's location bar, the transfer speed when copying from my xp/torrent box is almost doubled! I get just over 7MB/s that way. Which if memory serves is about the pace I was used to when I was booting xp on this computer (well, 10 minutes for dvd iso to transfer anyway, windows is not so kind as to give us actual transfer speed data in explorer..)

I tried changing the fstab entries for my samba mounts to start with the IP instead of the computer name, but that did not make any difference.

I'm still hoping someone can tell me (or point me to the doc that can) how I can set autonegotiation to be off at startup..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Azureus Won't Download/Upload dalponis Linux - Wireless Networking 12 12-06-2006 10:54 AM
Slow download fast upload to file server Fire! Linux - Networking 6 05-06-2006 05:07 AM
New Slackware box, upload Extremely slow, download normal? fireman949 Linux - Networking 1 02-10-2005 02:20 PM
upload/download speed slow only over WAN? Help Please slack_usr Slackware 19 12-07-2004 11:03 AM
hdd-related download problem(upload 4-5MB/s, download ~1MB/s) tine Linux - Hardware 4 09-15-2004 04:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration