LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-06-2016, 11:35 PM   #1
crazyalex
LQ Newbie
 
Registered: Sep 2004
Location: Boisbriand (QC), Canada
Distribution: Mint 17.3
Posts: 27

Rep: Reputation: 16
Slow and unstable wifi


Hi everyone!

I'm back here after a long time. I decided to get back on Linux and install Mint 17.3 on an old laptop (lenovo R61e) and encounter a problem I hope you can help me to solve.

I'm still very newbie to Linux, but I Googled my problem and only find old closed threads on other forums and no solution worked for me.

The problem is my wifi is very slow and unstable (around 1 to 4 mbps,constantly up and down on speedtest.net). If I go wired, everything is fine. The wifi also works good on Windows 7. Another thing is even if the card seem to be an Atheros AR242X / AR542X, the # on the sticker of the card is: ATH-AR5BXB63

Heres the lshw output:
Code:
crazyalex@CrazyLinux ~ $ sudo lshw -C network
  *-network               
       description: Wireless interface
       product: AR242x / AR542x Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 01
       serial: 00:1f:e1:65:ee:9e
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath5k driverversion=3.19.0-32-generic firmware=N/A ip=192.168.255.254 latency=0 link=yes multicast=yes wireless=IEEE 802.11bg
       resources: irq:17 memory:f7f00000-f7f0ffff
  *-network
       description: Ethernet interface
       product: NetLink BCM5787M Gigabit Ethernet PCI Express
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 02
       serial: 00:1e:37:cb:b0:b9
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.137 duplex=full firmware=sb v2.11 ip=192.168.1.13 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:29 memory:f8200000-f820ffff
Since I can't really use the wifi, I'm using the wired connection. So if a solution you want me to try need to turn off the wired connection, please tell me. Until then, I'll keep both connection on.

You'll probably need some more info, but I can't think of any right now, so just ask!

Thank you for you help.
 
Old 02-07-2016, 02:29 AM   #2
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 21 MATE, EndeavourOS, antiX, MX Linux
Posts: 4,014
Blog Entries: 34

Rep: Reputation: 1471Reputation: 1471Reputation: 1471Reputation: 1471Reputation: 1471Reputation: 1471Reputation: 1471Reputation: 1471Reputation: 1471Reputation: 1471
crazyalex,

Open the Terminal and type:

Code:
sudo -s
Press Enter. When prompted, type your password (not displayed for security reasons).

Press Enter again.

Next, copy & paste this line into Terminal:

Code:
echo "options ath5k nohwcrypt=1" > /etc/modprobe.d/ath5k.conf
Press Enter.

Code:
exit
Press Enter.

Close Terminal.

Reboot your computer.
 
Old 02-07-2016, 12:34 PM   #3
crazyalex
LQ Newbie
 
Registered: Sep 2004
Location: Boisbriand (QC), Canada
Distribution: Mint 17.3
Posts: 27

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by beachboy2 View Post
crazyalex,

Open the Terminal and type:

Code:
sudo -s
Press Enter. When prompted, type your password (not displayed for security reasons).

Press Enter again.

Next, copy & paste this line into Terminal:

Code:
echo "options ath5k nohwcrypt=1" > /etc/modprobe.d/ath5k.conf

Press Enter.

Code:
exit
Press Enter.

Close Terminal.

Reboot your computer.
Hi beachboy2 and thank you for your reply.

Unfortunately, it doesn't work. Maybe I need a new driver but I can't find one.
By the way, is it normal that the firmware is set to "N/A"?

Thank you again and have a nice day.
 
Old 02-09-2016, 08:54 PM   #4
crazyalex
LQ Newbie
 
Registered: Sep 2004
Location: Boisbriand (QC), Canada
Distribution: Mint 17.3
Posts: 27

Original Poster
Rep: Reputation: 16
Thumbs up [solved]

Ok guys, problem solve, and I still don't know what was the problem. I removed the wifi card, clean the connectors for the antennas and reinsert it.

Guest what? Everything works like a charm now. Strange.
 
Old 02-09-2016, 11:07 PM   #5
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 19,872
Blog Entries: 12

Rep: Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053Reputation: 6053
Quote:
Originally Posted by crazyalex View Post
Strange.
it's an interesting effect i have noticed many times:
  • make the switch from linux to windows
  • somewhat nervous about this; here be dragons.
  • awareness is HEIGHTENED
  • notice things you haven't noticed before
  • tend to connect these things with the most recent relevant change to the system = linux
it's purely psychological;
just like commercial operating systems use these psychological things inverted to give you the impression that your system is running faster.
 
Old 02-10-2016, 02:32 AM   #6
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 21 MATE, EndeavourOS, antiX, MX Linux
Posts: 4,014
Blog Entries: 34

Rep: Reputation: 1471Reputation: 1471Reputation: 1471Reputation: 1471Reputation: 1471Reputation: 1471Reputation: 1471Reputation: 1471Reputation: 1471Reputation: 1471
crazyalex,

Glad to hear that your problem is solved.

Those instructions are correct for the ath5k card, so perhaps your reinserting the card was enough to make it see sense.

Who knows?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] WLAN (Wifi) very unstable arijspieter Linux - Newbie 4 11-08-2012 08:03 PM
programs for diagnosing an unstable wifi signal? nkoplm Linux - Networking 2 12-01-2011 10:21 AM
[SOLVED] unstable wifi rbees Linux - Networking 7 08-28-2011 06:40 AM
Linux is slow and unstable! bluedude2288 Linux - General 26 09-26-2004 06:40 AM
slow and unstable LAN ZaphyR Linux - Networking 4 08-16-2004 05:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration