-   Linux - Networking (
-   -   Slackware won't recognize network card!! (

bmccorm2 10-14-2005 04:03 PM

Slackware won't recognize network card!!
I am currently trying to do a clean install of Slackware 10.1 and everything goes smooth except that it does not recognize my network card and I cannot connect to the internet. I am currently on a LAN network at school, so I just use the DHCP option. Here are all the relevant specs of my computer:

Dell Inspiron 5150
Network card: Intel(R) PRO/100 VE Network Connection

I have tried netconfig numerous times. After I boot the system, I always look under /etc/rc.d to try and find the rc.netdevice, but it is never there. I have manually looked through the rc.modules file to probe for the correct Intel network card, but still slackware cannot detect the card.

I have even tried to detect the network settings before I install the kernel to the hard drive, and it probes through all possible network cards, not finding a match.

I have looked extensively at the slackware webpage and all other relevant forums and informational pages but have not found any help. Does anyone have any ideas??

Thanks so much for any help you can give!

Tinkster 10-14-2005 04:37 PM

The first thing to check will be whether the module is
already loaded. Chances are that hot-plugging took
care of this for you.

What's the output of


mrigor 10-14-2005 04:42 PM

My first attempt to resolve the issue would be to open the kernel menuconfig and verify that all of the 10/100 network options are selected.

To reach this config, go to /usr/src/linux/make menuconfig.

After selecting either the appropriate driver or all of the drivers, I would then rebiuld the kernel. You can find several HOWTOs on the internet if you search for "build kernel". After building the kernel setup the boot loader with the old and the new kernel and see what happens.

Hope this helps.


bmccorm2 10-14-2005 06:53 PM

I'm sorry I am a little new to Linux so here goes:

Concerning the first reply, I went to the directory /etc/rc.d and ran
the command "Ismod" and the command was not recognized by the BASH.
Do I need to go to another directory so that this command will produce
some sort of output? Nevertheless, I don't think the module was
loaded because I read that the file rc.netdevice is created once the
network adapter is loaded, and that file is definitely not in the

Regarding the second reply, I went to the path /usr/src/linux/ and there was no directory "make" under that path. There was a directory called Makefile, but I don't think that is what I needed.

I am currently using the knoppix bootable DVD to access the Internet, and it configures the network card just fine (it uses the DHCP for an IP address and calls the network card eth0). Is there anything I can do in Knoppix to figure out what Slackware is missing?

Thanks again

PDock 10-14-2005 08:19 PM

Slackware includes lsmod in the a/module-init-tools-3.1......tgz package. Did you install that package?

ls /var/log/packages | grep module
With respect to which module to use for your nic card; sure use the lsmod from a command line in the knoppix boot. Might need ctrl-alt-f2 in knoppix to get to a command line; same with slackware when using lsmod.

good luck

bmccorm2 10-15-2005 07:10 AM

Ok I got the lsmod command installed and here is the output (just some of it because I couldn't copy it all down by hand!):

Module Size Used By
uhci 24284 0 unused
ehci - hcd 17516 0 unused
snd-intel8x0 18080 0
snd-intel8x0m 8708 0
snd-ac97-codec 54472 0 snd-intel8x0 snd-intel8x0m

Thanks again!

CWizard 10-16-2005 09:00 AM

I recently installed Slack 10.2 on a Dell Dimension 5100 with an integrated card. After installation the card was not found, but I didn't worry too much. I then, as was the plan, downloaded (through preinstalled WinXP) linux, compiled, and it worked. May, or may not, help you. Considering that you cross-posted this in the Newbie forum, you might not want to compile the kernel.

EDIT: Oops, I said linux 2.6.14...

bmccorm2 10-16-2005 10:39 AM

I don't know if I am comfortable recompiling the kernel yet, so until then, do you think there are any other ways to get slack to recognize the network card?

CWizard 10-16-2005 12:53 PM


Originally posted by bmccorm2
I don't know if I am comfortable recompiling the kernel yet, so until then, do you think there are any other ways to get slack to recognize the network card?
I don't know. It seems obvious that your current kernel and modules don't recognize the card, so you will probably need a new kernel somehow. Have you tried using the 2.6 kernel from the install cd (test26.s), instead of the default (bare.i)? It *might* do the trick.

Otherwise, compiling the kernel does not need to be that scary, if you're willing to take some risks:
* Get and untar the latest kernel into /usr/src
* Copy /kernels/test26.s/config (from the install cd) as /usr/src/linux-2.6.x/.config to have a template
* Run "make menuconfig", and maybe enable some network drivers
* Do "make" then "make modules_install"
* Do "cp .config /boot/config-2.6.x"
* Do "cp /boot/"
* Do "cp arch/i386/boot/bzImage /boot/bzImage-2.6.x"
* Edit lilo.conf, copy the section for your current kernel, but change image to match above and a new label.
* Run "lilo" so it writes the changes.
* Boot

If you're very unsure about this, don't do it, but it is not very hard. If something goes wrong you can always go back to the previous kernel from lilo's boot menu.

comprookie2000 10-16-2005 02:29 PM

Try as root modprobe e100
dhcpcd eth0 or whatever

All times are GMT -5. The time now is 01:06 PM.