LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Slackware 9, Windows XP, crossover cable and an internet connection (https://www.linuxquestions.org/questions/linux-networking-3/slackware-9-windows-xp-crossover-cable-and-an-internet-connection-98919/)

dxdad 10-01-2003 04:10 AM

Slackware 9, Windows XP, crossover cable and an internet connection
 
Hi, I've searched and searched through the forums and nothing quite answers my question.

Here is what I have:

---
Computer 1 (Mine)
Slackware 9
Network card

Computer 2 (Wife's)
Windows XP
Broadband (ADSL) internet connection
Network card

and
A crossover cable
---

This is what I want to do:
Connect the two PCs together and share the internet connection. The modem HAS to stay in the XP PC.

I don't want to have to buy ANY other hardware.

Could you tell me:
1. Is this possible?
and
2. Either:
- a) How do I do it?
or
- b) Where do I look to find out?

I've read through loads of HOWTOs and other documentation but I've not found anything that really helps.

I've never done any networking but i'm comfortable with Linux

raceprouk 10-01-2003 04:15 AM

networking windows and linux... hmm... :scratch:
i believe the samba tool is designed for this purpose

therefore, run the wizard on the xp machine, note the settings like IP address of xp machine, then configure samba. since i have not tried this before, i can only suggest. however, doing a google search should yield some good results.

hope this helps, even if only a little
:newbie::study:

dxdad 10-01-2003 04:19 AM

Am I right that I don't neet a hub or switch.

Phathead 10-01-2003 07:34 AM

No hub or switch is needed. You also don't need samba.

Turn on Internet connection sharing on the XP machine. I've used XP for about 5 minutes, so I'm not sure, but I think under the network connection that is the DSL modem (likely a PPPoE connection) you right click and then find the box that says enable Internet connection sharing.

This will (if it works the same as Win 2000) set the network card on the Windows computer to 192.168.0.1. You will need to setup the Slackware computer to use the default gateway of 192.168.0.1 and put it on the same subnet (192.168.0.x with netmask of 255.255.255.0). If XP doesn't do this, just use the address the XP network card is assigned. You do need a static IP address on this card.

When that is done (and the cable connected), you should be able to ping each of the computers. When you can do that, you should be able to get out to the Internet. You'll need to edit your /etc/resolv.conf file with the nameservers your ISP has given you to resolve DNS names. Just run 'man resolv.conf' if you don't know how to do this.

That should do it, please let me know if this doesn't work.

As an asside, make sure you have a firewall on the XP machine. At the very least Zone Alarm. Don't use the XP firewall, it's not really a firewall. When you setup the firewall make sure the network card connection is a trusted network so that it won't block outgoing Internet requests from the Slackware machine.

Phathead

[edit]
Oh yeah, you'll neet to edit /etc/rc.d/rc.inet1 to make the changes to the IP address and default gateway. And make sure to turn off DHCP.
[/edit]

dxdad 10-08-2003 05:55 PM

Well now. I eventually got the wire that I ordered from someone on eBay. I managed to connect though my wifes PC in win 98 on my PC - but that isn't a lot of use now is it ;-)

I've read the networking howto and although fasinating it seems to be based more on networking principals than actually doing it.

I edited the files in my /etc/rc.d to tell slackware an IP address and not to use DHCP. I also told it to use 192.168.0.1 as the gateway.

Now clearly the XP machine is configured as I am connected though it at the moment. But in Linux I can't ping the other computer.

Col Panic 10-08-2003 06:31 PM

when you configure the XP machine's Internet connection sharing you can use it as a DHCP server. Not a great one but it works. Try it that way and let the nix box grab an IP and gateway from the xp box.

dxdad 10-08-2003 07:31 PM

It doesn't ping with DHCP either.

I do "ifconfig eth0" and it seems to indicate that I have a valid IP address on my Linux machine.

Col Panic 10-08-2003 08:00 PM

stupid question for ya.....are they on the same subnet?
how about /etc/hosts.deny any references in there?
"" /etc/hosts
""/etc/hosts.allow

you say it worked with a win98 machine...you got them both to communicate? ie you sure its a crossover cable and not a straight cable?

dxdad 10-09-2003 03:53 AM

subnet is the same - 255.255.255.0

I haven't ever touched
etc/hosts.deny
/etc/hosts
/etc/hosts.allow

So i assume nothing bad in there - but I'll check in a minute when I reboot.

Difinately crossover as I am connected to internet though cable as I type.

dxdad 10-09-2003 06:07 AM

Just noticed when I load the kernel module for the network card the mouse won't work.

Col Panic 10-09-2003 08:51 AM

Is it a USB mouse by chance? Try disabling Plug and Play in your Bios and see if it fixes the mouse/nic conflict

It sounds like maybe your nic isn't set up correctly. Im not a slackware guru so Im not real sure of the hardware browsing/detection capabilities.....i'd try commenting it out of fstab and trying to reconfigure it.

dxdad 10-09-2003 01:10 PM

No, mouse is PS/2. Would it help disabling PnP in bios anyway?

fstab? That's just for mounting filesytstems isn't it? It is a 3Com Etherlink III ISA (3C509b-Combo) card - isapnp seems to initialise it sucessfully.

Col Panic 10-09-2003 02:13 PM

try disabling the pnp....can't hurt to try

and yes you're right of course....fstab is file systems....try modules.conf to get it not to load...been a rough day and too many open post windows :o

dxdad 10-09-2003 07:04 PM

OK, tried enabling and disabling PnP on bios.

When module loads there is no error. Tried letting it do it during linux starting and tried doing it manually and it gives no errors and seems to find the card's address.

Tried with DHCP and manually setting IP and gateway.

if i do "ifconfig" it tells me about "lo" and "eth0" and seems to indicate all is well.

but if i ping the XP machine it doesn't work. it tells me 100% packet loss etc.

psyklops 10-09-2003 08:47 PM

When you run ifconfig does it tell you that eth0 is "up" a long with a bunch of hardware and memory addresses?

And have you tried to ping 127.0.0.1 to make sure the nic card is functioning?


All times are GMT -5. The time now is 02:14 PM.