-   Linux - Networking (
-   -   Slackware 2nd nic config problem (

NewbieUser 02-15-2003 09:56 AM

Slackware 2nd nic config problem
Hello, (sorry this is the completed second post.. i accidentally pressed submit before finishing my first post)

Slackware 8.1
eth0 Linksys LNE100TX v4 IRQ10 0xe400-e4ff
eth1 DLink DFE-530TX+ IRQ11 0xe800-e8ff

Problem: second nic will not load for the life of me.

I've been counting the number of hairs that's been falling out.. lost count in the 80's. Been trying to install a second nic card for the past several days. I think I've pretty much read everything and tried everything that's been posted on the web, in the cd documents, in an old Linux book (redhat.. can't afford to buy another book right now), and have been on chat lines.

In the system information under PCI and I/O- ports both the nics show up. However under Network Interfaces only eth0 and lo shows up. Both ethercards works fine when only one of them are installed at a time. So I think it's a configuration problem.

I've tried everything from editing conf.modules to lilo.conf.
Things that I have tried:
conf.modules- alias eth1=tulip
alias eth1 driver
alias net -pf-4 off (i was getting desperate)
lilo.conf- append = eth0,0,eth1
append ether=10,0xe400,eth0 ether=11,0xe800,eth1

rc.inet1- tried adding "ifconfig eth1 <my ip> netmask <subnet mask> broadcast <broadcast> up"
tried to configure the ip addresses for eth1
tried disabling PNPOS setting in Bios (read that somewhere)

Now, of all the suggestions I found in rc.inet1 - "edit /etc/rc.d/rc.modules to load the support at boot time." How? I went to that file and it lead me to think that I needed to get the driver for the eth1 card. And things got more and more complicated.

Another suggestion I found was here on this board posted last year that seems more closely related:

"ok, what your problem is is that redhat and most other linux distros treat network initilization differently than slackware. here's how you'll wanna add eth1 to your system:

in your network initilization script - which is /etc/rc.d/rc.inet1 - you'll want to duplicate the section in which it loads eth0 (which is pretty much everything after your loopback device).

i modified my rc.inet1 script a little in order to have it make more sense to me. i removed all of the eth0 init lines from that file and moved them to a separate file called "rc.eth0" (which i created). then i copied rc.eth0 to rc.eth1 and modified any mention of that file so that instead of "eth0" it read "eth1". then i changed my network settings according to what i wanted eth1 to be configured as. finally, you'll want to specify the device name, so add the line:


to the top of your config variables (IPADDRESS, GATEWAY, etc).

then in rc.inet1 where the eth0 lines used to be, i simply add the following:


of course, you could always skip the new file process and simply duplicate the eth0 config section to reflect eth1, i just like the new files for the reason of clarity.

after you've done this, reinitilize your network by typing:


and you should see eth1 configured and ready to roll! hope this helps. :-)"

In rc.inet1 for slackware 8.1 "everything after loopback device" are scripts that shouldn't be modified? right? I'm not sure what should and should not be modified according to this member.

He seems to be addressing the problem that I'm having, but I'm not sure if the file he's talking about are written the same way as the slack 8.1 file that I'm looking at.

I'm confused, exhausted and would really appreciate any kind of info to lead me in the right direction. Better yet, it would be great if someone can just write out the script that I need so I can stop guessing and make this freaking nic work already... sorry.


wartstew 02-15-2003 01:03 PM

I think the DFE-530TX uses the VIA-rhine driver, not the tulip.

Do a "modprobe via-rhine", then do an "lsmod" and see if it loaded. If so, continue with the "ifconfig ..." stuff and see if it all works.

All times are GMT -5. The time now is 09:00 PM.