LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-18-2007, 08:15 AM   #16
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,733

Rep: Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835

I think that this guide will help you.
 
Old 12-18-2007, 08:33 AM   #17
.id
LQ Newbie
 
Registered: Dec 2007
Distribution: Slackware 12
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
I think that this guide will help you.
I tried as suggested in this guide and it didnt help. One thing is strange however when I run netconfig and choose DHCP I dont get screen with possibility to probe, I have to input DHCP hostname (which I dont have, so i leave it empty) and then it jumps right to the end of configuration with message "Settings accepted. Basic network configuration is complete". One more thing, when I try to enable network adapter in KDE control center following error is shown: "could not change device state" (maybe that could help you somehow).
 
Old 12-18-2007, 08:50 AM   #18
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,733

Rep: Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835
Did you ran
Code:
/etc/rc.d/rc.inet1
after configuring your network?
 
Old 12-18-2007, 08:55 AM   #19
.id
LQ Newbie
 
Registered: Dec 2007
Distribution: Slackware 12
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
Did you ran
Code:
/etc/rc.d/rc.inet1
after configuring your network?
Yes I did but nothing happened.
 
Old 12-19-2007, 01:46 AM   #20
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,733

Rep: Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835
Running /etc/rc.d/rc.inet1should look for a dhcp server to get an IP address, so your problem might be somewhere else. Take a look at the various log files in /var/log to see if you find any errors.
 
Old 12-19-2007, 03:26 AM   #21
.id
LQ Newbie
 
Registered: Dec 2007
Distribution: Slackware 12
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
Running /etc/rc.d/rc.inet1should look for a dhcp server to get an IP address, so your problem might be somewhere else. Take a look at the various log files in /var/log to see if you find any errors.
Omg, is it so hard to provide documentation. KDE is killing me! I was trying do delete settings file or something and re-enable platform selection in network configuration (kde control center) but i cant manage to find any info about that. Searching for relevant log files didnt produce any result either. Is it reinstallation of system my only option?? Maybe if you could tell me what log file in particular to look for. Or could i somehow reinstall only kde from pkgtool (is it possible to do that?).
 
Old 12-19-2007, 04:20 AM   #22
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,733

Rep: Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835
I don't use KDE, but I think that configuring your network using the KDE control center is going to edit the same system config files. So there is no need to uninstall/reinstall KDE or reinstall Slackware. If you manage to configure your network using Slackware tools, KDE will use the same settings.
What you mean that nothing happens when running /etc/rc.d/rc.inet1? Does it produce any output?
Take a look at /etc/rc.d/rc.inet1.conf to see if you have:
Code:
USE_DHCP[0]="yes"
Relevant log files are /var/log/messages, /var/log/debug and /var/log/syslog
 
Old 12-19-2007, 04:42 AM   #23
General Failure
Member
 
Registered: Jan 2007
Location: Germany
Distribution: Slackware 13.37
Posts: 387

Rep: Reputation: 36
Check again if the module is loaded. Post your rc.inet1.conf (in CODE tags) and the output of ifconfig -a please.
 
Old 12-19-2007, 05:02 AM   #24
.id
LQ Newbie
 
Registered: Dec 2007
Distribution: Slackware 12
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
I don't use KDE, but I think that configuring your network using the KDE control center is going to edit the same system config files. So there is no need to uninstall/reinstall KDE or reinstall Slackware. If you manage to configure your network using Slackware tools, KDE will use the same settings.
What you mean that nothing happens when running /etc/rc.d/rc.inet1? Does it produce any output?
Take a look at /etc/rc.d/rc.inet1.conf to see if you have:
Code:
USE_DHCP[0]="yes"
Relevant log files are /var/log/messages, /var/log/debug and /var/log/syslog
THANK YOU THANK YOU THANK YOU. I cant find words to express my gratitude! It works now, after checking rc.inet1.conf:

Code:
bash-3.1# cat rc.inet1.conf | grep USE_DHCP
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
USE_DHCP[0]="yes"
USE_DHCP[1]="" <- wtf??
USE_DHCP[2]=""
USE_DHCP[3]=""
#USE_DHCP[4]="yes"
bash-3.1# vi rc.inet1.conf
...
USE_DHCP[1]="yes"
... saved changes
bash-3.1# ./rc.inet1 
Polling for DHCP server on interface eth1:
dhcpcd: MAC address = 00:0c:29:b0:a1:2f
dhcpcd: your IP address = 192.168.74.129
bash-3.1# ping www.google.com
PING www.l.google.com (64.233.183.99) 56(84) bytes of data.
64 bytes from nf-in-f99.google.com (64.233.183.99): icmp_seq=1 ttl=128 time=56.1 ms
64 bytes from nf-in-f99.google.com (64.233.183.99): icmp_seq=2 ttl=128 time=55.8 ms

--- www.l.google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1002ms
rtt min/avg/max/mdev = 55.864/55.988/56.112/0.124 ms
 
Old 12-19-2007, 05:27 AM   #25
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,733

Rep: Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835
So your nic was eth1 and not eth0, that's why it didn't work at a first place.
Anyway glad to see you've made it.

Regards
 
Old 12-19-2007, 05:37 AM   #26
PDock
Member
 
Registered: Aug 2004
Distribution: Slack10 & curr. tried numerous
Posts: 189

Rep: Reputation: 37
Don't need most of this as my timing and typing are slow and off. Glad things are running.


We need your response to General Failure requested info. I think most here are assuming you are giving answers form your normal installation and NOT your vmware install. Please give all answers from the normal installation.

Did you modify /etc/rc.d/rc.modules as suggested and the pcnet32 module is getting loaded on reboot? If NOT the easiest way to have your pcnet32 module loaded on reboot is as root
Code:
cat pcnet32 > /etc/rc.d/rc.netdevice
Under windows what is shown after opening a command prompt window and
Code:
ipconfig /all
?

Now you have a choice you can modify /etc/rc.d/rc.inet1.conf such that
Code:
USE_DHCP[1]="yes"
(note: [1])
or manually enter your windows numbers in the appropriate [1] fields.
 
Old 12-19-2007, 06:02 AM   #27
.id
LQ Newbie
 
Registered: Dec 2007
Distribution: Slackware 12
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by PDock View Post
Don't need most of this as my timing and typing are slow and off. Glad things are running.


We need your response to General Failure requested info. I think most here are assuming you are giving answers form your normal installation and NOT your vmware install. Please give all answers from the normal installation.

Did you modify /etc/rc.d/rc.modules as suggested and the pcnet32 module is getting loaded on reboot? If NOT the easiest way to have your pcnet32 module loaded on reboot is as root
Code:
cat pcnet32 > /etc/rc.d/rc.netdevice
Under windows what is shown after opening a command prompt window and
Code:
ipconfig /all
?

Now you have a choice you can modify /etc/rc.d/rc.inet1.conf such that
Code:
USE_DHCP[1]="yes"
(note: [1])
or manually enter your windows numbers in the appropriate [1] fields.
I cant give you info about my "normal" installation of slack because right now i dont have it at my disposal.
 
Old 12-19-2007, 06:24 AM   #28
PDock
Member
 
Registered: Aug 2004
Distribution: Slack10 & curr. tried numerous
Posts: 189

Rep: Reputation: 37
No need just replicate what you did there.

good luck
 
Old 08-04-2008, 09:06 PM   #29
bluecell
LQ Newbie
 
Registered: Jan 2008
Posts: 9

Rep: Reputation: 0
Thank you all for your good job, I solved my similar problem based on your solution. Here is my laptop configuration:

dell latitude d400
vmware 6
slackware 10
kernel 2.4

solution is:
#modprobe pcnet32
#netconfig eth0 up
#ifconfig eth0 192.168.72.80 netmask 255.255.255.0 up
#route add default gw 192.168.72.1
#lsmod
#route -e

Last edited by bluecell; 08-04-2008 at 09:18 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ethernet card won't enable itturnstoashes Linux - Networking 3 04-18-2007 10:04 AM
ethernet card SiS 900-Based PCI Fast Ethernet Adapter Not Detected pathan_azhar Linux - Networking 0 08-13-2006 04:15 AM
Can't enable wired ethernet gregleimbeck Linux - Networking 7 04-14-2006 10:29 AM
How do I get USB-Ethernet adapter working in Slackware 10.2 JAwuku Slackware 3 01-13-2006 03:39 PM
Network Problems with Slackware 9.1 and VIA Compatible Fast Ethernet Adapter Hell Cheese Slackware 13 06-07-2004 11:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration