LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-18-2007, 02:53 AM   #1
.id
LQ Newbie
 
Registered: Dec 2007
Distribution: Slackware 12
Posts: 15

Rep: Reputation: 0
slackware 12: why i cant enable ethernet adapter


Hi everybody, I'm having troubles with configuration of my network card in newly installed slackware 12. I have two installations, one as guest system in vmware player running on win xp, and other installed normally. The network adapter is driving me crazy in both cases, the situation is identical. After installation i wanted to enable ethernet adapter and I tried to do that with KDE Control Center -> Network settings. Firs annoyance was dialog with message that my platform is not supported and therefore I have to choose one of the proposed. I choose FreeBSD 6 and enabled my ethernet adapter and it worked. I was happy for that short period of time. After first reboot, I found out that my ethernet adapter was disabled. Again I choose platform (free BSD 6) and enabled my ethernet adapter. Everything was ok until I filled checkbox that say remember selected platform. After next reboot my ethernet is still disabled and I cant enable it (but message platform not supported is not shown anymore) it says: "There was an error changing the device's state. You will have to do it manually". Well I tried enabling it manually with

# /etc/rc.d/rc.inetd start

but without success.

I cant find solution anywhere (and beleive me i tried).

Please help me
 
Old 12-18-2007, 03:24 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,733

Rep: Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835
You can run
Code:
netconfig
from CLI to configure your network
 
Old 12-18-2007, 03:30 AM   #3
.id
LQ Newbie
 
Registered: Dec 2007
Distribution: Slackware 12
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
You can run
Code:
netconfig
from CLI to configure your network
I alredy did that, but netconfig does not provide hardware configuration (I cant enable my ethernet adapter), in netconfig I can only select what I use dhcp, static ip...
 
Old 12-18-2007, 03:41 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,733

Rep: Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835
What is your nic model? If it's recognized by the kernel, then the appropriate module is loaded into the kernel and netconfig can configure it for you and write the necessary info into /etc/rc.d/rc.inet1.conf.
If you don't know your nic's model, run
Code:
lspci
 
Old 12-18-2007, 04:17 AM   #5
.id
LQ Newbie
 
Registered: Dec 2007
Distribution: Slackware 12
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
What is your nic model? If it's recognized by the kernel, then the appropriate module is loaded into the kernel and netconfig can configure it for you and write the necessary info into /etc/rc.d/rc.inet1.conf.
If you don't know your nic's model, run
Code:
lspci
This is from my vmware virtual maschine:

bash-3.1# lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 01)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 01)
00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 08)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
00:0f.0 VGA compatible controller: VMware Inc [VMware SVGA II] PCI Display Adapter
00:10.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] (rev 10)

How can I found out if my module is supported or not? One more thing, I dont understand why my network adapter worked properly if my module is not loaded in kernel?
 
Old 12-18-2007, 04:25 AM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,733

Rep: Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835
Quote:
How can I found out if my module is supported or not? One more thing, I dont understand why my network adapter worked properly if my module is not loaded in kernel?
According to http://www.faqs.org/docs/ethernet/Ethernet-HOWTO-4.html, your nic is supported by the stock linux kernel (using module pcnet32). You have to run (as root)
Code:
modprobe pcnet32
to load the kernel module into kernel. Then run netconfig to configure your network.
If your nic worked properly before, that means that the module was loaded automatically by the KDE network configuration tool.
 
Old 12-18-2007, 04:43 AM   #7
.id
LQ Newbie
 
Registered: Dec 2007
Distribution: Slackware 12
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
According to http://www.faqs.org/docs/ethernet/Ethernet-HOWTO-4.html, your nic is supported by the stock linux kernel (using module pcnet32). You have to run (as root)
Code:
modprobe pcnet32
to load the kernel module into kernel. Then run netconfig to configure your network.
If your nic worked properly before, that means that the module was loaded automatically by the KDE network configuration tool.
modprobe pcnet32 dont help, did following:

1. modprobe pcnet32 (as root)
2. reboot
3. logged in as root and run netconfig
4. tried to ping google, didnt work
5. tried again modprobe pcnet32, ping dont work again
6. starx
7. go to KDE control center - network settings, still same message.. it wont enable my network adapter
 
Old 12-18-2007, 04:54 AM   #8
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,733

Rep: Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835
Your should run:
modprobe pcnet32
netconfig (to configure your network)

There is no need to reboot. It's not Window$. Just make sure the settings you put in netconfig are correct.
 
Old 12-18-2007, 06:09 AM   #9
gopi.d
Member
 
Registered: Feb 2006
Location: India
Distribution: Slackware 12, Fedora 7, Kubuntu-7.04
Posts: 172

Rep: Reputation: 30
if you are able to see the ethernet interface then it's already done. just add the /sbin/modprobe pcnet32 to rc.modules to enable it automatically during booting. run netconfig eth0 and configure your ip configurations. now run ifconfig eth0 up to bring up your ethernet interface.
 
Old 12-18-2007, 06:10 AM   #10
.id
LQ Newbie
 
Registered: Dec 2007
Distribution: Slackware 12
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
Your should run:
modprobe pcnet32
netconfig (to configure your network)

There is no need to reboot. It's not Window$. Just make sure the settings you put in netconfig are correct.
I did everything as you suggested but it still dont work. The thing is that i doubt that netconfig can help me because everything is setup properly within it. Is there any way to enable/activate my network adapter from CLI?
 
Old 12-18-2007, 06:16 AM   #11
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,733

Rep: Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835
Mind that ping may not work, so it's not a good tool to test connectivity. You can use your browser to try to connect.
Anyway after doing everything suggested, run:
Code:
lsmod
ifconfig
route -e
to verify the module is loaded, your nic is configured correctly and you have the correct gateway setup.
 
Old 12-18-2007, 06:17 AM   #12
.id
LQ Newbie
 
Registered: Dec 2007
Distribution: Slackware 12
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by gopi.d View Post
if you are able to see the ethernet interface then it's already done. just add the /sbin/modprobe pcnet32 to rc.modules to enable it automatically during booting. run netconfig eth0 and configure your ip configurations. now run ifconfig eth0 up to bring up your ethernet interface.
This didnt help either:

Code:
bash-3.1# netconfig eth1 (i dont have eth0 is that ok?)

bash-3.1# ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:0C:29:B0:A1:2F  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:16 Base address:0x1080 

bash-3.1# ping www.google.com
ping: unknown host www.google.com
 
Old 12-18-2007, 06:23 AM   #13
.id
LQ Newbie
 
Registered: Dec 2007
Distribution: Slackware 12
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
Mind that ping may not work, so it's not a good tool to test connectivity. You can use your browser to try to connect.
Anyway after doing everything suggested, run:
Code:
lsmod
ifconfig
route -e
to verify the module is loaded, your nic is configured correctly and you have the correct gateway setup.
Is this ok?

bash-3.1# lsmod | grep pcnet32
pcnet32 33668 0
mii 8576 1 pcnet32

bash-3.1# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:352 errors:0 dropped:0 overruns:0 frame:0
TX packets:352 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:22228 (21.7 KiB) TX bytes:22228 (21.7 KiB)

bash-3.1# route -e
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
loopback * 255.0.0.0 U 0 0 0 lo

Tried browser but it still doesnt work (bytheway i appreciate your effort very much)
 
Old 12-18-2007, 07:08 AM   #14
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,733

Rep: Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835
So the module is loaded fine, but your network is not configured. Did you ran netconfig after loading the module?
If you have a static IP you can run:
Code:
ifconfig eth0 xx.xx.xx.xx netmask yy.yy.yy.yy up
route add default gw zz.zz.zz.zz
 
Old 12-18-2007, 07:26 AM   #15
.id
LQ Newbie
 
Registered: Dec 2007
Distribution: Slackware 12
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
So the module is loaded fine, but your network is not configured. Did you ran netconfig after loading the module?
If you have a static IP you can run:
Code:
ifconfig eth0 xx.xx.xx.xx netmask yy.yy.yy.yy up
route add default gw zz.zz.zz.zz
Yes, I did run netconfig after loading the module (few times actually). I'm not sure if static IP can help me because everything was fine before with DHCP. I didn't change anything in environment except the selection of checkbox "remember selected platform" in dialogbox during network configuration in kde control center.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ethernet card won't enable itturnstoashes Linux - Networking 3 04-18-2007 10:04 AM
ethernet card SiS 900-Based PCI Fast Ethernet Adapter Not Detected pathan_azhar Linux - Networking 0 08-13-2006 04:15 AM
Can't enable wired ethernet gregleimbeck Linux - Networking 7 04-14-2006 10:29 AM
How do I get USB-Ethernet adapter working in Slackware 10.2 JAwuku Slackware 3 01-13-2006 03:39 PM
Network Problems with Slackware 9.1 and VIA Compatible Fast Ethernet Adapter Hell Cheese Slackware 13 06-07-2004 11:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration