-   Linux - Networking (
-   -   Slackware * Cisco VPN client issue (

mmoser63 12-28-2004 11:39 AM

Slackware * Cisco VPN client issue
I have a (fairly) plain Slackware 8.1 laptop that has been running OK for quite some time. It's an older box that I use for website development, so I'm reluctant to change it. I use a PCMCIA hard-wired network card and DHCP to connect to 2 different networks, home and office. Up until a few days ago, this worked well - I could surf, email, ftp, ssh, from either home (roadrunner) or the office lan.

Then I installed the Cisco VPN client, version 4.6.

I can still connect at home, surf, ftp, email, and so forth. I can start up the vpnclient and connect to the office network, email, surf, ftp, etc. BUT, when I connect at work, I can no longer surf or email, or acess anything outside my own subnet. I can ping/ssh to addresses on my local subnet. Other stations on the subnet can ftp, surf, ssh, email to the rest of the world.

I've checked the IP address (same as before, the DHCP server is letting me have it again), the routing table is OK (despite the fact that the behavior suggests a routing table problem). The vpnclient_init daemon(?) is NOT started by default, I start it manually when i want to use the VPN.

I'm befuddled (and so is the network engineer who tried to help me.

Any advice would be appreciated.

mmoser63 12-28-2004 03:17 PM

UPDATE: I uninstalled the Cisco VPN client. No change in behavior. Installing the client changed something that I haven't found yet.


All times are GMT -5. The time now is 03:25 PM.