LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-19-2004, 02:18 AM   #1
seingoku
Member
 
Registered: Mar 2003
Posts: 34

Rep: Reputation: 15
slack 10 static IP


I need to have static ip for my slack 10box. It works fine with dhcp so i know that the cable and nic are good. After I run netconfig and fill out all the info i get
Destination host unreachable.
It has assigned the IP correctly I can ping 192.168.5.8
standard mask
gateway 5.5 destination host unreachable
this is a routing error but it seems that the gateway ip is not binding for one reason or another.
The netwrk shows up in /etc/networks.
Is there another way to set the gateway? I read through ifconfig and didn't se anything.
 
Old 07-19-2004, 02:23 AM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
Check /etc/rc.d/rc.inet1.conf. It keeps all ip related config.
 
Old 07-19-2004, 02:33 AM   #3
seingoku
Member
 
Registered: Mar 2003
Posts: 34

Original Poster
Rep: Reputation: 15
ok checked it and the gateway is set correctly
I also reran rc.inet1 and after still dest host unreachable
any other ideas?
Don't know if this helps
It is a newly compiled kernel
unfortunatly it did work with dhcp after the compile
so I know there is comunication to the router
this is sticky or maybe its me
 
Old 07-19-2004, 02:38 AM   #4
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
can you check the routing entries

netstat -nr ;

and post the output of

/sbin/ifconfig
 
Old 07-19-2004, 02:52 AM   #5
seingoku
Member
 
Registered: Mar 2003
Posts: 34

Original Poster
Rep: Reputation: 15
destination gateway genmask flags mss win irt iface
192.168.5.0 0.0.0.0 255.255.255.0 u 0 0 0 etho
127.0.0.0 0.0.0.0 255.0.0.0 u 0 0 0 lo
0.0.0.0 192.168.5.5 0.0.0.0 ug 0 0 0 eth0

i never lookedat this before but it looks good to me
what do you think?
 
Old 07-19-2004, 03:04 AM   #6
seingoku
Member
 
Registered: Mar 2003
Posts: 34

Original Poster
Rep: Reputation: 15
here is ifconifg
inet addr: 192.168.5.8 bcast:192.168.5.255 mask 255.255.255.0
 
Old 07-19-2004, 03:05 AM   #7
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
Is 192.168.5.5 your gateway? Can you ping from the gateway to your system?

Can you try going back to DHCP and check whether everything works good? Is 5.8 the same IP that is leased to you by DHCP?

Is any firewall running on either of the PCs?

Last edited by ppuru; 07-19-2004 at 03:07 AM.
 
Old 07-19-2004, 03:06 AM   #8
seingoku
Member
 
Registered: Mar 2003
Posts: 34

Original Poster
Rep: Reputation: 15
yes
i have suse 9.1 and win both static work fine
 
Old 07-19-2004, 03:42 AM   #9
seingoku
Member
 
Registered: Mar 2003
Posts: 34

Original Poster
Rep: Reputation: 15
to the rest of your s ?
no firewall
dhcp works fine
not same IP and can't ping from gateway/ its a dlink router
other hosts cant ping 5.8 but that is obviuos b/c 5.8 can't ping the gateway
one thing
if i have static ip set do i need to have routed running?
 
Old 07-19-2004, 03:59 AM   #10
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
another question ... are the dhcp leased address and your current static address on the same subnet - that is, 192.168.5.0
 
Old 07-19-2004, 04:03 AM   #11
seingoku
Member
 
Registered: Mar 2003
Posts: 34

Original Poster
Rep: Reputation: 15
yup they sure are
i disbaled the dhcp server
my other systems work fine with same type of config (static, 192.168.5)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto Assign Multiple Static Public IP Addresses under SBC's PPPoE Static Ip system o trekgraham Linux - Networking 8 04-17-2007 10:51 AM
No sound in slack 10.0, just static! metcalfe Slackware 6 05-10-2005 01:18 PM
Sound static since slack 10.1 (alsa 1.0.8) daspooky Slackware 7 03-15-2005 06:44 AM
FC2 Overriding static if in favor of dhcp system set for static pkraus109 Linux - Networking 8 09-21-2004 11:13 AM
Slack 10.0 static IP problem ERTW Linux - Networking 5 07-23-2004 12:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration