LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-16-2004, 12:50 AM   #1
rsumbeling
Member
 
Registered: Nov 2004
Location: Toronto, Ontario
Distribution: slackware, redhat
Posts: 42

Rep: Reputation: 15
Unhappy Slack 10 proFTP: Always incorrect password!


Hi Linux masters,

I am now setting up the proFTP on my slack 10 as ftp service, but everytime I logged into it from a remote machine, say a windows-based machine, I am always denied access into it and proFTP always say that my password is incorrect, even though im 100% sure that my log in info is correct.

I tried removing the word "ftp" on the /etc/ftpusers file. but i still get the same error message that login is failed:

------------
C:\>ftp 172.23.88.251
Connected to 172.23.88.251.
220 ProFTPD 1.2.9 Server (ProFTPD Default Installation) [pofsbctrain.pof.apa.ene
t.accenture.com]
User (172.23.88.251none)): zzsumbra
331 Password required for zzsumbra.
Password:
530 Login incorrect.
Login failed.
ftp>
------------

now inside my /etc/ftpusers file:
-------------
#
# ftpusers This file describes the names of the users that may
# _*NOT*_ log into the system via the FTP server.
# This usually includes "root", "uucp", "news" and the
# like, because those users have too much power to be
# allowed to do "just" FTP...
#
#
# Version: @(#)/etc/ftpusers 3.00 02/25/2001 volkerdi
#
# Original Author: Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org>
#
# The entire line gets matched, so no comments or extra characters on
# lines containing a username.
#
# To enable anonymous FTP, remove the "ftp" user:
root
uucp
news

# End of ftpusers.
-------------

what seems to be wrong with this? help please?

thanx
 
Old 11-16-2004, 01:13 AM   #2
SirSlappy
Member
 
Registered: Jun 2003
Location: Glendale AZ
Distribution: Slackware 10
Posts: 153

Rep: Reputation: 30
post your /etc/proftpd.conf file please.

JS
 
Old 11-16-2004, 01:56 AM   #3
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
My proftp in Slak wouldn't let me log in as anyone with a null shell (except maybe the ftp user but I have anon logins off.) Maybe you are running into the same thing? To test anonymous login log in to the ftp server with username anonymous or ftp and password being anything with an @ and a . in it such as test@nohost.com or whatever. You could also log in using a user/pass that has a valid local system login (I only recomend this over your local LAN.)
 
Old 11-16-2004, 09:31 AM   #4
rsumbeling
Member
 
Registered: Nov 2004
Location: Toronto, Ontario
Distribution: slackware, redhat
Posts: 42

Original Poster
Rep: Reputation: 15
Hey sirslappy

Here's the copied and pasted /etc/proftpd.conf file...

Please, please let me know what might be the problem and what should i do...

Thanks a lot!!!

-----------
-----------
# This is a basic ProFTPD configuration file.
# It establishes a single server and a single anonymous login.
# It assumes that you have a user/group "nobody" and "ftp"
# for normal/anonymous operation.

ServerName "ProFTPD Default Installation"
#ServerType standalone
ServerType inetd
DefaultServer on

# Port 21 is the standard FTP port.
Port 21
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask 022

# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances 30

# Set the user and group that the server normally runs at.
User nobody
Group nogroup

# This next option is required for NIS or NIS+ to work properly:
#PersistentPasswd off

SystemLog /var/log/proftpd.log
TransferLog /var/log/xferlog

# Normally, we want files to be overwriteable.
<Directory /*>
AllowOverwrite on
</Directory>

# A basic anonymous FTP server configuration.
# To enable this, remove the user ftp from /etc/ftpusers.
<Anonymous ~ftp>
RequireValidShell off
User ftp
Group ftp
# We want clients to be able to login with "anonymous" as well as "ftp"
UserAlias anonymous ftp

# Limit the maximum number of anonymous logins
MaxClients 50

# We want 'welcome.msg' displayed at login, and '.message' displayed
# in each newly chdired directory.
DisplayLogin welcome.msg
DisplayFirstChdir .message

# Limit WRITE everywhere in the anonymous chroot
<Limit WRITE>
DenyAll
</Limit>

# An upload directory that allows storing files but not retrieving
# or creating directories.
# <Directory incoming/*>
# <Limit READ>
# DenyAll
# </Limit>
#
# <Limit STOR>
# AllowAll
# </Limit>
# </Directory>

</Anonymous>
-----------
 
Old 11-16-2004, 12:46 PM   #5
SirSlappy
Member
 
Registered: Jun 2003
Location: Glendale AZ
Distribution: Slackware 10
Posts: 153

Rep: Reputation: 30
when you attempt to login, what does your /var/log/proftpd.log say?
 
Old 11-16-2004, 12:58 PM   #6
rsumbeling
Member
 
Registered: Nov 2004
Location: Toronto, Ontario
Distribution: slackware, redhat
Posts: 42

Original Poster
Rep: Reputation: 15
Hi SirSlappy,

The last line of the file that u said -> /etc/proftpd.conf, that when i tried to login (failed again "incorrect login") was:


Nov 17 01:52:38 pofsbctrain proftpd[2098] pofsbctrain.pof.apa.enet.accenture.com (172.23.88.25[172.23.88.25]): FTP session opened.
Nov 17 01:52:44 pofsbctrain proftpd[2098] pofsbctrain.pof.apa.enet.accenture.com (172.23.88.25[172.23.88.25]): SECURITY VIOLATION: r
oot login attempted.
Nov 17 01:53:39 pofsbctrain proftpd[2098] pofsbctrain.pof.apa.enet.accenture.com (172.23.88.25[172.23.88.25]): FTP session closed.


Please let me know if u have any solution...

thanx
 
Old 11-17-2004, 01:43 AM   #7
SirSlappy
Member
 
Registered: Jun 2003
Location: Glendale AZ
Distribution: Slackware 10
Posts: 153

Rep: Reputation: 30
well, that log shows that you're trying to login FTP as root. Which it will not allow. Is that user set UID 0?

Try logging in with a user that's not root.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
login incorrect before password ourlinuxid Linux - Security 4 01-22-2005 02:35 AM
530 Login incorrect & proftp 80s Linux - Newbie 7 05-11-2004 09:06 PM
ProFTP-adding user and password ? lostboy Linux - General 1 07-04-2003 09:03 AM
incorrect password (can single, but can't su) david_reno Linux - Software 2 06-19-2003 10:42 PM
incorrect password when logging in as su - DMB Linux - General 3 07-09-2002 04:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration