-   Linux - Networking (
-   -   sis900 card and redhat 9 (

dimkal 09-10-2003 08:06 PM

sis900 card and redhat 9
Hello all. I have a problem with getting my ethernet card to work.

I have a double partitioned machine Windows XP and RedHat 9.0. On my windows partition cable modem connects flawlessly to the computer and everything works well. On my Linux partition i get an error during bootup, were eth0 fails. I've tried a X program, neat without much luck. How do I go about fixing it??

according ethernet-howto sis900 has been supported for a while -- since kernel version 2.2. I also must mention that when i had a
Mandrake 9.2 running on this machine it had no problem resolving the ethernet card and connecting me to internet.

Can somebody tell me where to start. I'd like to avoid recompiling
kernel modules since i don't know what I'm doing.

digianswer 09-10-2003 08:29 PM

add this line to your "/etc/modules.conf"

alias eth0 sis900

then restart networking with this command

"/etc/rc3.d/S10network reload"

then see what you get with "ifconfig"

If you still don't see the interface
"cat /etc/sysconfig/network-scripts/ifcfg-eth0"

and tell us what you get. Also let us know the error the interface gives


dimkal 09-10-2003 10:46 PM

the line you've described is already in my modules.conf files.

alias eth0 sis900

dimkal 09-10-2003 11:01 PM

here are the results from requested commands....

[root@chad dimka]# /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:40:CA:49:8E:68
RX packets:20540 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:1246983 (1.1 Mb) TX bytes:3420 (3.3 Kb)
Interrupt:5 Base address:0xec00

lo Link encap:Local Loopback
inet addr: Mask:
RX packets:2137 errors:0 dropped:0 overruns:0 frame:0
TX packets:2137 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:154374 (150.7 Kb) TX bytes:154374 (150.7 Kb)

[root@chad dimka]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.

ugenn 09-11-2003 06:11 AM

the card *is* detected and the drivers loaded. your problem lies somewhere else. Some things for you to consider...

- Is your IP supposed to be assigned manually or dynamically?
- Are you masquerading/firewalled?
- Have you paid your ISP bill?

fenka 11-02-2003 08:25 AM

I have a similar problem. Also using Redhat 9 and have a sis900 embedded LAN. The sis appears to be working fine, and I've tried everything that I found on various forums regarding this.

I can enable the eth0 connection, which supposedly patches me into a splitter. I've set the connection with all the same options that work on my XP partition. When I try to set up ppoe though, it fails to initialise.

Also, when I try to run a test on the eth0, or maybe limit its speed to 10 Mb, I get an answer that it can't find the device. Any ideas?

zaubara 11-19-2003 06:44 PM

Again, the same error! Something seems to make serious trouble on those new distribs ...

xdistant 11-19-2003 06:50 PM

i have the same problem which i've posted about but within mandrake 9.2 RC2. i've also tried using the National Semiconductor NIC that i have in my other pc running XP and that also failed to connect to my router (using DHCP) using the natsemi driver. maybe it's not the driver but some other configurations i don't have setup correctly

All times are GMT -5. The time now is 02:05 PM.