LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-16-2004, 05:32 AM   #1
crazyswede
Member
 
Registered: Jan 2004
Posts: 30

Rep: Reputation: 15
Simple problem FSTAB File - User settings 'uid=xxx'


I am still learning so please be nice to me

When I mount the HD I want more than one person to be able to write from WinXP (samba). I have put one user (see below) in fstab 'uid=501', which works. How to I also include user 502. I do not know how to write it (format). Been trying different things.

/dev/hda5 /fat32/archive vfat defaults,uid=501 0 0

thanks

crazyswede
 
Old 02-16-2004, 05:48 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 681Reputation: 681Reputation: 681Reputation: 681Reputation: 681Reputation: 681
Use gid=xxx. This will allow you to place particular members in the group and give them permissions to the drive. This is the linux method of Access Control Lists.
Mandrake has a group set up for this. It is called fileshare. Adding users to this group, and using gid=fileshare option will give these members full access to the mounted partition.

note: In my fstab, I have my user name spelt out. I assume this also works for group idīs also, but I havenīt tried it.

For a vfat drive with user access, you may want to also use the nodev option.
 
Old 02-16-2004, 10:17 AM   #3
crazyswede
Member
 
Registered: Jan 2004
Posts: 30

Original Poster
Rep: Reputation: 15
I have set up the group id before and I tried it again and it does not work

It only works if I put uid=501 or uid=502 but not with gid=100 (which is the group id.

How can I do 'uid=' which includes both 501 and 502>

What is 'nodev'?
 
Old 02-17-2004, 04:10 AM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 681Reputation: 681Reputation: 681Reputation: 681Reputation: 681Reputation: 681
Are you certain that both users are members of group gid=100. Do you have Ļumask=0Ļ option on the line? Try using names instead of numbers in the gid= and uid= entries.

nodev
Do not interpret character or block special devices on the file system.
 
Old 02-17-2004, 06:53 AM   #5
crazyswede
Member
 
Registered: Jan 2004
Posts: 30

Original Poster
Rep: Reputation: 15
They are all the in the same group...mmm.

I removed unmask before... I will put it back and try again.

Even if I use names for uid= ... how do I put multple user names?
 
Old 02-18-2004, 05:14 AM   #6
crazyswede
Member
 
Registered: Jan 2004
Posts: 30

Original Poster
Rep: Reputation: 15
I got it working now... thank you very much for your help

I got it working using gid= ....but one problem that slowed me down was that I wrote 'unmask=000' instead of 'umask=000'
 
Old 02-19-2004, 01:57 AM   #7
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 681Reputation: 681Reputation: 681Reputation: 681Reputation: 681Reputation: 681
The answer to your question about more then one uid= entry, I don't think that would work. More than one user is a group of users. That is what groups are for! Access is controlled when you determine who is in the group. You may want to use your own username in the uid= entry. Also, come to think of it, you want to change the umask to 007 to deny all access to others.

Another thing, make sure you create the group before you enter the gid= entry.
 
Old 02-19-2004, 04:59 PM   #8
crazyswede
Member
 
Registered: Jan 2004
Posts: 30

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by jschiwal
The answer to your question about more then one uid= entry, I don't think that would work. More than one user is a group of users. That is what groups are for! Access is controlled when you determine who is in the group. You may want to use your own username in the uid= entry.
That logic suddenly hit me when I was messing around with the settings before!

...and I thought that I was clever
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Error, some other host already uses address XXX.XXX.XXX.XXX" mwbb_support Linux - Networking 5 01-20-2014 09:59 AM
sudo /usr/bin/chroot /home/chroot /bin/su - xxx| /bin/su: user xxx does not exist saavik Linux - General 3 07-04-2007 11:30 AM
Problem getting connection with a DLink Router with IP 10.xxx.xxx.xxx kezira Fedora 9 11-28-2005 11:31 PM
Problem getting connection with a DLink Router after setting static IP 10.xxx.xxx.xxx kezira Linux - Networking 1 11-09-2005 11:27 PM
Host XXX.XXX.XXX.XXX is not allowed to connect to this MySQL server ocavid Linux - Newbie 2 03-16-2005 10:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration