LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-14-2015, 02:41 PM   #1
Lnthink
Member
 
Registered: May 2010
Location: Lafayette, LA
Distribution: Ubuntu, RH, Fedora
Posts: 44

Rep: Reputation: 11
Shorewall rule for accepting PXE (4011)


Greetings,

I'd like to add a rule to shorewall "rules" file that allows 4011 for PXE boot.

I've got part of this done for allowing PXE boot:
TFTP/ACCEPT pvt $FW

The above service is viewable and working...


so I'd like the same for PXE...
so, is there a rule like this?

PXE/ACCEPT pvt $FW


Is PXE a keyword that I can use?

I guess what this problem gets down to is, where is the keyword list for the shorewall RULES file? I found "THE" link for the rules file on their website, however, the document never seems to get into the classes of service that I can choose from to allow/deny/forward, etc.

All rules to date in this server's "rules" file are indicated by service... TFTP, HTTP, etc. - so I've got no example to try just a plain port number.

If there is no PXE service keyword, how do I change the syntax to accept port 4011?

Would it be:
4011/ACCEPT pvt $FW

?

Any help kindly appreciated.
PS All changes and restarts to shorewall interrupt service are momentarily disruptive, so I'd like to get this down with as few retries as possible. I felt I needed to explain why I just didn't try the "PXE/ACCEPT" rule outright before asking for help.

Last edited by Lnthink; 05-14-2015 at 02:43 PM. Reason: rewording
 
Old 05-14-2015, 05:16 PM   #2
Lnthink
Member
 
Registered: May 2010
Location: Lafayette, LA
Distribution: Ubuntu, RH, Fedora
Posts: 44

Original Poster
Rep: Reputation: 11
Post

Ok I got it.
I added this to the "rules" file.
I then ran "shorewall check" and made sure it was good.
Then, I just restarted shorewall.

Accept pvt $FW tcp 4011

That's all it took.
 
  


Reply

Tags
firewall, pxe, pxe boot, shorewall


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Using Rsyslog to redirect Shorewall messages but Shorewall is not a facility dman777 Linux - Software 3 06-22-2018 05:23 PM
issue with uefi pxe boot on rhel 6.5 as pxe server geekmaxwell Linux - Networking 3 04-02-2014 02:27 PM
[SOLVED] Snort - DynamicPlugin: Rule [##] not enabled in configuration, rule will not be used mhollis Linux - Software 3 08-29-2011 06:06 PM
pxe boot "PXE-T01 file not found" ssharma_02 Linux - Networking 16 05-18-2011 03:21 PM
shorewall config question with /etc/shorewall/rules peter72 Linux - Networking 3 01-01-2007 09:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration