-   Linux - Networking (
-   -   sharing internet connection(modem) (

linuxfan 10-18-2000 05:24 AM

Two rh6.1, one connected to internet through modem. Both are able to ping each other. When I added a ppp0 gateway and interface, the internet connection stopped with the error message "can't authenticate the remote computer". I ran the command $route add default ppp0 and the response was "SIOCADDRT: no such device".

Can somebody help.

anti 10-19-2000 08:23 AM


how did you

add[ed] ppp0 gateway and interface

Usually the pppd set's the default route automatically.

Did you use pppconfig to setup the link to your ISP ?
Is your uplink working at all ?
If yes, why do you try to change the default route ?

Which kernel are you running ?
Which services do you want to work ?
http+ftp -> install squid.
"everything" -> compile NAT in you kernel and use ipchains to set it up.

More questions than answers, but your info was simply not enough.


linuxfan 10-19-2000 04:38 PM

I solved the problem. Now I have internet connection sharing.

Thanks for your response.

anti 10-20-2000 04:53 AM

No problem.

But to help the next one stumbling into the same pit.

Where was the problem ?

All times are GMT -5. The time now is 12:04 PM.