-   Linux - Networking (
-   -   sharing & using a printer on network WITHOUT Samba (

pusrob 01-12-2007 03:35 PM

sharing & using a printer on network WITHOUT Samba

The situation:
I have a HP USB printer, and it is connected to the "big" PC. I have a laptop too, and it is in an other room. I have a wireless router too, and both computers are connected to it ("big" PC with LAN, laptop with WLAN). I have Mepis Linux on both computers.
The question:
How to use my printer from my laptop, WITHOUT using Samba? What to configure and where (router, firewall, CUPS...)? For simplicity: I need a linux to linux networked printer.

kilgoretrout 01-12-2007 04:01 PM

That's pretty easy, i.e. linux to linux printer sharing. You set it up using cups and the kde printer configuration tools. On the big machine, configure your printer in the kde control center>peripherals>printers using the HP hpijs driver. On the laptop, you do the same except you select the "Network Printer" option or "Remote Cups"(I think either will work), instead of "local printer".. You will need to select the hpijs driver during the laptop printer configuration as well IIRC. You will also have to know the ip address of the big box on the LAN which is given by the router and you may have to adjust your firewall settings but I didn't have to do anything on mine. However, I'm not running mepis. Actually, this was much easier than doing samba printer configuration. Just dive right in to the kde control center printer configuration section and tick add new printer; it's pretty self explanatory.

pusrob 01-13-2007 12:49 PM

Hello kilgoretrout!

Well, I have to tell you, that it is not that simple. I tried what you said, but I don't know what to write to one part. So: I go to the KControl, peripherials, printers, admin mode, add new printer, Remote CUPS server (IPP/HTTP). Here comes the user identification. Should I write here my username and password, or the root and password, or Anonymous? After that the remote IPP server comes. What to write to the Host part? The name of big computer, the IP of big computer, or what? If I write the name, it sais it cannot connect to it. If I type the IP, it doesn't do anything (maybe it freezes). What next? If I go to the Network printer w/IPP (IPP/HTTP) section, it asks for printer URI. What to write here? I typed a lot of things here, and when I press the IPP report button an error message comes:

Unable to generate report. IPP request failed with message: client-error-forbidden (0x401)
. On my big comp this is written to the printer URI in kcontrol:

What is localhost, and what is localdomain? Thanks.

kilgoretrout 01-13-2007 04:00 PM

Choose anonymous login. Under host, type in the numeric ip of the big box. If you don't know what that is, go to the big box, open a console, su to root and run:

# ifconfig

Look at the "inet address" entry for eth0. On many home routers this will be in the form After entering the ip, hit the Next button and you should see your HP printer on the big box listed. If you get this far, it means cups successfully found your printer through the network. Now you continue through the configuration choosing the hpijs driver just like you did for the big box; it's pretty much identical from here to what you did on the big box.

pusrob 01-15-2007 07:18 AM

Dear kilgoretrout!

Thanks for your kind help. I tried the IP thing again, but it didn't work first. I didn't know why. Than, I checked out my firewall on both systems, but IPP was allowed. I still didn't understand what's the problem. Than I realised, that my firewall config prog (guarddog) uses the internet and local zones, and the firewall config is not the same for them. I check out the IPP in the local section, and it wasn't checked. I checked it in on both systems, and now, the printer setup tool can see the printer.
Why didn't I think about this in the first time? Such a little and stupid problem...
Now, I can see the printer, but it does not print anything. Why? It shows, that the printer is stopped. I press the start button, and it sais "processing", than it is stopped again. I can't start the printer (It is turned on in the same time). One more thing. How can I delete out a printer from cups? When I press the delete button, it sais, it is forbidden. Any ideas?

All times are GMT -5. The time now is 09:19 PM.