-   Linux - Networking (
-   -   Setup DNS, WEB, FTP, and Mail Server Help! (

dcdjservices 08-06-2003 09:21 AM

Setup DNS, WEB, FTP, and Mail Server Help!
I have Redhat 7.3 on my Gateway. I want to start an online hosting service and have access to the server through SmartFTP. I want email like I have already configured my Nameserver but I do not know if they are correct. They are,, and I registered them through so accepted them to configure. I still do not know how to get it working. I hosted previously with but changed to my server. I do not know how to setup the Apache Web Server, Email Server, FTP Server, MYSQL Server, and Other Servers I might need. I bought a $20.00US book that told me to access some files that weren't even there! I really need help! I told somebody that I might be able to host them if I got my server working and they are all happy. I really also won't to get all the DNS right and it be through my domain. I do not want to use somebody like that provides free DNS. HELP!!!


Mara 08-06-2003 10:23 AM

How have you configured the servers (nameserver part)? What's exactly done?

dcdjservices 08-06-2003 10:25 AM

I have my Nameservers configured to redirect to the IP Address of My Computer. Is that correct? Also, do you have yahoo IM or AOL IM so we can chat about the problem. It takes forever to do so throuh a public forum? That is how I configured it. I haven't configured my email server, FTP server, MYSQL Server, ect.

sashhoney 08-07-2003 03:08 AM

i suggest u to test ur name server setting using commands like dig and nslookup.
well if u post ur named.conf, that will be really helpful for me to understand it properly
i suppose u have installed everything from ur RH7.3 CD
1. For Apache:
u need not do so much thing for that
a. enable httpd using ntsysv command.
b. now store ur accebile html files in /var/www/html directory which is ur default directory
c. restart httpd server by using command service httpd start
2.For Sendmail:
a. enable sendmail from ntsysv
b. now u have to modify /etc/mail/ and /etc/mail/access files
u can find extensive help in /usr/share/sendmail{ver}/README

3.For mysql:
u need to enable only mysqld using ntsysv
and run service mysqld start

dcdjservices 08-07-2003 08:38 AM

Ill try it. Also, when I try to start my HTTP server, it says that the program cannot be found. Where could I download the HTTP Web Server or how could I fix this. Once I found the place to download it, how would I install it?

dcdjservices 08-07-2003 08:50 AM

Sorry, Im new to this,
how do you open ntsysv? I don't even know what that is! Sorry, this is my first time setting a web server and mail server.

dcdjservices 08-07-2003 08:53 AM

Also, can you walk me through the step of configuring those files for send mail. I do not know what to do! If you want to talk about it through IM. I'll tell you my IM Addresses which will help talking faster.

Yahoo IM: dcdjservices
AOL IM: linuxredhat73web

Thanks again for all your help!

MasterC 08-07-2003 03:04 PM

Moving to Linux - Networking Forum

dcdjservices 08-07-2003 03:07 PM

I am downloading Redhat 9. Redhat 8 and Mandrake 9 never booted on my computer. Do you think that Redhat 9 will? Everybody I ask says that I can get a better server if I use Redhat 8 or 9. I guess I'll try it. Do you think that Ill boot? If not, Ill have to start asking how to get it booting.

dcdjservices 08-07-2003 03:07 PM

I hate Linux 8 cuz it never worked period. I worked for 2 weeks and it never booted. Ill try 9 but ill prop do the same thing.

dkaplowitz 08-07-2003 06:21 PM

It's not really going to matter that much which version you run. I encourage you not to run to the easy way out and reinstall your OS. You're going to be left with the same issues when you get to your networking setup.

You are asking a lot in one thread, with the DNS, mail, web, etc... Since DNS is the most important thing for you to get setup for all these services, why don't you focus on getting that nailed, then moving on to mail and/or step at a time?

So, where are you with your DNS setup?

rogerbennett 08-08-2003 05:18 AM

I've also got a DNS problem on Red Hat 7.3
From the howto I've managed to get bind to start, but dig doesnt ever supply an answer. /var/log/messages gives me one error about a file not ending in a linefeed, which i'm sure is causing the problem but fundementally the file in question *does* have several empty lines at the end of it, so must end in a linefeed.

I want to be running DHCP on the same machine, so will eventually move to DDNS. so while i was thinking about DNS I've decided to get dhcpd running.

To test it I booted a w2k client (most workstations are running doze). Now the only range in /etc/dhcpd.conf is with a subnet of However the w2k client was assigned a 169.something IP with a subnet of

Any clues?

dcdjservices: Stick with the flavour of linux you have got. Moving to a newer redhat of mandrake isnt going to fix the problem if its your config of lack of understanding thats causing the problem.

Get just DNS working first - either as a caching only server or Authorative on your zone or both. Once bind loads with no errors, and dig works then add additional RRs for your mail or other stuff.
Does bind start OK ? can you dig your loopback or your own IP ?

sashhoney 08-08-2003 06:22 AM

DCDJSERVICES:about ntsysv:
well just go to terminal window and write ntsysv
u will have a menu from which u can choose the daemons u want to run at startup

well if u can post the concerned file, that will be really helpful

rogerbennett 08-08-2003 06:44 AM

here are the contents of /etc/dhcpd.conf

when I add random junk to this file and start the dhcpd I get errors, so i'm pretty sure it is reading this file.
Also, how do I stop dhcpd to reload the config ? I've been killing it with its PID... is there a better way ?

# dchpd.conf ripped from the howto
default-lease-time 600;
max-lease-time 7200;
option subnet-mask;
option broadcast-address;
option routers;
option domain-name-servers;
option domain-name "waterside.lan";

subnet netmask {

please excuse the domain name. This dhcp/dns setup is currently for a private network not connected to the internet. When the gateway works I'll probably buy/rent a domain name or something.

dcdjservices 08-08-2003 04:30 PM

I talked to a guy who has been using Redhat for a while and he said that using a newer version came with newer programs. I know that I am going to go to the same problem, but I might as well have the most updated system. I am installing Linux Redhat 9 now. I upgraded it from Redhat 7.3 but did not select to upgrade the boot config since when I did a clean install, it never completed booting. Do you think that it will boot now? I may need help getting it booting since I lost my Redhat 7.3 disks. If I can never get Redhat 9 working, then I'll have to download the IOS files for Redhat 7.3 and re-install it. But, I am hoping that Redhat 9 will work correctly and boot. Doesn't come with a new version of Bind and Apache? Also, I can not figure out my IP address. I tried using a IP website to find it out, but, it gave me the IP address to the T1 box outside. I would use my friends internet connection to dial up through a 56k connection to find it, but my modem isn't compadible with Linux. It said so when I tried to install Linux Redhat and mandrake.

All times are GMT -5. The time now is 01:52 PM.